summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmartinez-mirror2021-04-09 12:15:41 -0500
committerlmartinez-mirror2021-04-09 12:15:41 -0500
commit843dd15736207b1d834fe80554895bc13ea7a591 (patch)
tree1f96fffc8404d0fb718a4bed9568b3b3749afd0c
downloadaur-843dd15736207b1d834fe80554895bc13ea7a591.tar.gz
initial commit based off zpm pkgbase
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD28
-rw-r--r--zpm-git.install3
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b92916f71181
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = zpm-git
+ pkgdesc = A plugin manager for zsh
+ pkgver = r1151.205c1f2
+ pkgrel = 1
+ url = https://github.com/horosgrisa/zpm
+ install = zpm-git.install
+ arch = any
+ license = LGPL3
+ makedepends = git
+ depends = zsh
+ replaces = zpm
+ source = zpm-git::git+https://github.com/horosgrisa/zpm
+ sha256sums = SKIP
+
+pkgname = zpm-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..34594dc5d776
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+##
+!PKGBUILD
+!.SRCINFO
+!zpm-git.install
+!.gitignore
+
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5a525f6d6c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: lmartinez-mirror
+# Contributor: Grigorii Horos <horosgrisa@gmail.com>
+pkgname=zpm-git
+pkgver=r1151.205c1f2
+pkgrel=1
+pkgdesc="A plugin manager for zsh"
+arch=('any')
+url="https://github.com/horosgrisa/zpm"
+license=('LGPL3')
+depends=('zsh')
+makedepends=('git')
+install="$pkgname.install"
+replaces=('zpm')
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find bin functions lib plugins zpm.zsh \
+ -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/zpm/{}" \;
+ install -Dm 644 zshrc "$pkgdir/usr/share/zpm/zshrc-example.zsh"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/zpm-git.install b/zpm-git.install
new file mode 100644
index 000000000000..02c1e2209ae8
--- /dev/null
+++ b/zpm-git.install
@@ -0,0 +1,3 @@
+post_install () {
+ echo "You have to execute 'cp /usr/share/zpm/zshrc-example.zsh ~/.zshrc' to use it."
+}