summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-10-07 23:38:33 +0300
committerorhun2020-10-07 23:38:33 +0300
commit8413a32ecd82b3c486356a1ffd3d0961117d1c96 (patch)
tree8262f31e3dc3d86bfd3222859d32f996d9544e3c
parenta347100369c8218ed6b7aa18e4e5dd8dda22e759 (diff)
downloadaur-8413a32ecd82b3c486356a1ffd3d0961117d1c96.tar.gz
upgpkg: zps-bin 1.2.3-1
upstream release Update package details
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6e14e810e24..e8714c134ccc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,13 +5,18 @@ pkgbase = zps-bin
url = https://github.com/orhun/zps
arch = x86_64
license = GPL3
+ provides = zps
conflicts = zps
conflicts = zps-git
- source = https://github.com/orhun/zps/releases/download/1.2.3/zps-1.2.3.tar.gz
- source = https://github.com/orhun/zps/releases/download/1.2.3/zps-1.2.3.tar.gz.sig
validpgpkeys = 39E678DF63BE20EA5A175156B928720AEC532117
- sha512sums = 13fa805228957b56a4849cee92814533648be843b5b8a29709c33b8c8e240922735439c6dc48832da6c182a3c5d50f7406a1c6a37f090502dd9eeebf4142a0b8
- sha512sums = SKIP
+ source_x86_64 = https://github.com/orhun/zps/releases/download/1.2.3/zps-1.2.3.tar.gz
+ source_x86_64 = https://github.com/orhun/zps/releases/download/1.2.3/zps-1.2.3.tar.gz.sig
+ source_x86_64 = zps-1.2.3-LICENSE::https://github.com/orhun/zps/raw/1.2.3/LICENSE
+ source_x86_64 = zps-1.2.3-README.md::https://github.com/orhun/zps/raw/1.2.3/README.md
+ sha512sums_x86_64 = 13fa805228957b56a4849cee92814533648be843b5b8a29709c33b8c8e240922735439c6dc48832da6c182a3c5d50f7406a1c6a37f090502dd9eeebf4142a0b8
+ sha512sums_x86_64 = SKIP
+ sha512sums_x86_64 = d361e5e8201481c6346ee6a886592c51265112be550d5224f1a7a6e116255c2f1ab8788df579d9b8372ed7bfd19bac4b6e70e00b472642966ab5b319b99a2686
+ sha512sums_x86_64 = 08d14ec5ac6fd1a512c2491762059db8bcc169ef6e257c1e58488783193eb70dbba469853dc1b3230f00a06a22e90b9c36b0e96c577f062083ec7b9df511bc5b
pkgname = zps-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9f0907c0c1e1..8871d9bf8f1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,11 +9,18 @@ arch=('x86_64')
url="https://github.com/orhun/zps"
license=('GPL3')
conflicts=("${pkgname%-bin}" "${pkgname%-bin}-git")
-source=("$url/releases/download/$pkgver/${pkgname%-bin}-$pkgver.tar.gz"{,.sig})
-sha512sums=('13fa805228957b56a4849cee92814533648be843b5b8a29709c33b8c8e240922735439c6dc48832da6c182a3c5d50f7406a1c6a37f090502dd9eeebf4142a0b8'
- 'SKIP')
+provides=("${pkgname%-bin}")
+source_x86_64=("$url/releases/download/$pkgver/${pkgname%-bin}-$pkgver.tar.gz"{,.sig}
+ "${pkgname%-bin}-$pkgver-LICENSE::$url/raw/$pkgver/LICENSE"
+ "${pkgname%-bin}-$pkgver-README.md::$url/raw/$pkgver/README.md")
+sha512sums_x86_64=('13fa805228957b56a4849cee92814533648be843b5b8a29709c33b8c8e240922735439c6dc48832da6c182a3c5d50f7406a1c6a37f090502dd9eeebf4142a0b8'
+ 'SKIP'
+ 'd361e5e8201481c6346ee6a886592c51265112be550d5224f1a7a6e116255c2f1ab8788df579d9b8372ed7bfd19bac4b6e70e00b472642966ab5b319b99a2686'
+ '08d14ec5ac6fd1a512c2491762059db8bcc169ef6e257c1e58488783193eb70dbba469853dc1b3230f00a06a22e90b9c36b0e96c577f062083ec7b9df511bc5b')
validpgpkeys=('39E678DF63BE20EA5A175156B928720AEC532117') # orhun <orhunparmaksiz@gmail.com>
package() {
- install -Dt "$pkgdir/usr/bin/" "$srcdir/${pkgname%-bin}"
-} \ No newline at end of file
+ install -Dm 755 "${pkgname%-bin}" -t "$pkgdir/usr/bin"
+ install -Dm 644 "${pkgname%-bin}-$pkgver-README.md" "$pkgdir/usr/share/doc/${pkgname%-bin}/README.md"
+ install -Dm 644 "${pkgname%-bin}-$pkgver-LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-bin}/LICENSE"
+}