summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-09-14 01:35:29 +0300
committerorhun2020-09-14 01:35:29 +0300
commit1cfd9c8742ebd1e83e018c744dd2d780bde2b96c (patch)
tree83e2cb6f2a2526895223950576be4cf4edbc0d24
parent68447a9d6835c259a1c3ee78c0d5cf86db3646cc (diff)
downloadaur-1cfd9c8742ebd1e83e018c744dd2d780bde2b96c.tar.gz
upgpkg: zps-git 1.2.3.r0.g9d08c49-1
upstream release Update makedepends and install README.md
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a86e6b4c8486..3812f28fb8d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,7 @@ pkgbase = zps-git
url = https://github.com/orhun/zps
arch = any
license = GPL3
+ makedepends = git
makedepends = cmake
conflicts = zps
conflicts = zps-bin
diff --git a/PKGBUILD b/PKGBUILD
index 810a9adf6d31..13799c35ca9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgrel=1
arch=('any')
url="https://github.com/orhun/zps"
license=('GPL3')
-makedepends=('cmake')
+makedepends=('git' 'cmake')
conflicts=("${pkgname%-git}" "${pkgname%-git}-bin")
source=('git://github.com/orhun/zps.git')
sha256sums=('SKIP')
@@ -28,4 +28,5 @@ build() {
package() {
cd "${pkgname%-git}/build"
make DESTDIR="$pkgdir" install
+ install -Dm 644 "../README.md" -t "$pkgdir/usr/share/doc/${pkgname%-git}"
}