summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaximumadmin2021-02-26 21:02:12 +0900
committermaximumadmin2021-02-26 21:02:12 +0900
commitb0d664cddcd6480724d47912d94f5ed3ad2bdc9c (patch)
treecc93a22a4f8c64a6ae09aa6ac270f48e17edc655
downloadaur-b0d664cddcd6480724d47912d94f5ed3ad2bdc9c.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc271ef6b407
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = zramd
+ pkgdesc = Automatically setup swap on zram
+ pkgver = 0.8.2
+ pkgrel = 1
+ url = https://github.com/maximumadmin/zramd
+ arch = any
+ license = MIT
+ makedepends = go
+ depends = util-linux
+ conflicts = systemd-swap
+ conflicts = zramswap
+ conflicts = zram-generator
+ conflicts = zram-generator-git
+ source = https://github.com/maximumadmin/zramd/archive/0.8.2.tar.gz
+ sha256sums = 610f260e839ce17962c88dfee435a166a241cf2568df7619260dc432d060b380
+
+pkgname = zramd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cec695452b62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: maximumadmin <mxmadm@protonmail.com>
+
+pkgname=zramd
+pkgver=0.8.2
+pkgrel=1
+pkgdesc="Automatically setup swap on zram"
+arch=('any')
+url="https://github.com/maximumadmin/zramd"
+license=('MIT')
+depends=('util-linux')
+makedepends=('go')
+conflicts=('systemd-swap' 'zramswap' 'zram-generator' 'zram-generator-git')
+source=("https://github.com/maximumadmin/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('610f260e839ce17962c88dfee435a166a241cf2568df7619260dc432d060b380')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ go mod download
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ make release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 ${pkgname}.bin "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dm644 extra/${pkgname}.service -t "${pkgdir}/usr/lib/systemd/system/"
+ install -Dm644 extra/env "${pkgdir}/etc/default/${pkgname}"
+}