summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaximumadmin2021-05-16 22:42:40 +0900
committermaximumadmin2021-05-16 22:42:40 +0900
commitb6a3ec103c8b61bd44ec1c3c85575600d8ea182e (patch)
tree9583ab2189d2d82b6fe0242929bed8c30a9950ab
parentcc2efdbd43f4829a020be58ba08193cb88da691d (diff)
downloadaur-b6a3ec103c8b61bd44ec1c3c85575600d8ea182e.tar.gz
Local GOPATH
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55c2eb1aaef4..f48ab9508e4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: maximumadmin <mxmadm@protonmail.com>
+# Maintainer: maximumadmin <mxmadm at protonmail dot com>
pkgname=zramd
pkgver=0.8.8
-pkgrel=1
+pkgrel=2
pkgdesc="Automatically setup swap on zram ✨"
arch=('any')
url="https://github.com/maximumadmin/zramd"
@@ -10,7 +10,10 @@ license=('MIT')
depends=('util-linux')
makedepends=('go')
optdepends=('earlyoom: userspace oom daemon')
-conflicts=('systemd-swap' 'zramswap' 'zram-generator' 'zram-generator-git')
+conflicts=('systemd-swap'
+ 'zramswap'
+ 'zram-generator'
+ 'zram-generator-git')
backup=('etc/default/zramd')
source=("https://github.com/maximumadmin/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('b0464e4b33b0e9365c45d1f608d620f13879d464eac259a9e0e37eb1402f2654')
@@ -18,12 +21,12 @@ sha256sums=('b0464e4b33b0e9365c45d1f608d620f13879d464eac259a9e0e37eb1402f2654')
build() {
cd "$pkgname-$pkgver"
local commit_date="${COMMIT_DATE:-$(date --iso-8601=seconds)}"
- VERSION="$pkgver" COMMIT_DATE="$commit_date" make
+ GOPATH="${srcdir}/go" VERSION="$pkgver" COMMIT_DATE="$commit_date" make
}
check() {
cd "$pkgname-$pkgver"
- make test
+ GOPATH="${srcdir}/go" make test
}
package() {