summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-02-17 04:58:54 +0000
committerAlexandros Theodotou2019-02-17 04:58:54 +0000
commit38672f17fbe9320ba60395d5cc6dfc895ae3d2e0 (patch)
tree8b4cbdc4458836fac83b488d48cec45fc22e8c55
parent3b1970435dc642b7ea88e95e6ac108c549ac92e4 (diff)
downloadaur-38672f17fbe9320ba60395d5cc6dfc895ae3d2e0.tar.gz
use statically linked suil and libcyaml
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 20 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8aadfec27d8a..d30bcb2fd01b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,25 @@
pkgbase = zrythm
pkgdesc = Free GNU/Linux music production system (DAW)
pkgver = master
- pkgrel = 2
+ pkgrel = 3
url = https://git.zrythm.org/zrythm/zrythm
arch = x86_64
license = GPL3
depends = gtk3
depends = lv2
depends = lilv
- depends = suil
depends = jack
depends = libsndfile
depends = libsmf
depends = libdazzle
- depends = libcyaml
depends = breeze-icons
depends = portaudio
depends = ffmpeg
source = https://git.zrythm.org/zrythm/zrythm/-/archive/master/zrythm-master.tar.gz
+ source = git+https://github.com/tlsa/libcyaml.git
+ source = git+https://git.zrythm.org/zrythm/suil.git
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = zrythm
diff --git a/PKGBUILD b/PKGBUILD
index 264966274427..9e202ad0eb11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,36 @@
-# Maintainer: Alexandros Theodotou <alex at alextee dot org>
+# Maintainer: Alexandros Theodotou <alex at zrythm dot org>
pkgname=zrythm
pkgver=master
-pkgrel=2
+_pkgname="$pkgname-$pkgver"
+pkgrel=3
pkgdesc="Free GNU/Linux music production system (DAW)"
arch=('x86_64')
url="https://git.zrythm.org/zrythm/zrythm"
license=('GPL3')
-depends=('gtk3' 'lv2' 'lilv' 'suil' 'jack' 'libsndfile' 'libsmf' 'libdazzle' 'libcyaml'
+depends=('gtk3' 'lv2' 'lilv' 'jack' 'libsndfile' 'libsmf' 'libdazzle'
'breeze-icons' 'portaudio' 'ffmpeg')
-source=("https://git.zrythm.org/zrythm/zrythm/-/archive/$pkgver/zrythm-$pkgver.tar.gz")
-md5sums=('SKIP')
+source=("$_pkgname::https://git.zrythm.org/zrythm/zrythm/-/archive/$pkgver/zrythm-$pkgver.tar.gz"
+ "libcyaml::https://github.com/tlsa/libcyaml/archive/v0.1.0.tar.gz"
+ "suil::https://git.zrythm.org/zrythm/suil/-/archive/master/suil-master.tar.gz")
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
- cd "zrythm-$pkgver"
+ cd "$srcdir/$_pkgname"
+ cp -r $srcdir/libcyaml-0.1.0/* ./ext/libcyaml/
+ cp -r $srcdir/suil-master/* ./ext/suil/
}
build() {
- cd "zrythm-$pkgver"
+ cd "$srcdir/$_pkgname"
autoreconf -fi
./configure --prefix=/usr --enable-aur-build
make
}
package() {
- cd "zrythm-$pkgver"
+ cd "$srcdir/$_pkgname"
make DESTDIR="$pkgdir/" install
}