summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-06-05 11:08:18 +0100
committerAlexandros Theodotou2019-06-05 11:08:18 +0100
commit54e4a2107691cd644e0c8a7e09eea4eb61e7df3c (patch)
tree4b693b28760550c00e500cc2cdfeb29c2ff31bcd
parenta315a5cea28d86b5dfa6191b8cdb83be7f9ae8d5 (diff)
downloadaur-54e4a2107691cd644e0c8a7e09eea4eb61e7df3c.tar.gz
bump version 0.5.007
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d5c55859852..b5b8ca805cfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zrythm
pkgdesc = An highly automated, intuitive, Digital Audio Workstation (DAW)
- pkgver = 0.4.151
+ pkgver = 0.5.007
pkgrel = 1
url = https://git.zrythm.org/zrythm/zrythm
arch = x86_64
@@ -8,7 +8,8 @@ pkgbase = zrythm
makedepends = python
makedepends = gettext
makedepends = sed
- makedepends = libtool
+ makedepends = meson
+ makedepends = ninja
depends = gtk3
depends = lv2
depends = lilv
@@ -20,13 +21,12 @@ pkgbase = zrythm
depends = qt5-base
depends = libsamplerate
depends = alsa-lib
- depends = ffmpeg
depends = portaudio
depends = ladspa
depends = fftw
conflicts = zrythm-git
- source = https://git.zrythm.org/zrythm/zrythm/-/archive/v0.4.151/zrythm-v0.4.151.tar.gz
- md5sums = 5eebcbb84df1ad1d8c79f3fb94e87cec
+ source = https://git.zrythm.org/zrythm/zrythm/-/archive/v0.5.007/zrythm-v0.5.007.tar.gz
+ md5sums = 0f54a1b6228373841078331dd345f25a
pkgname = zrythm
diff --git a/PKGBUILD b/PKGBUILD
index de40905f9b3a..f0c6dfa6227a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alexandros Theodotou <alex@zrythm.org>
pkgname=zrythm
-pkgver=0.4.151
+pkgver=0.5.007
pkgrel=1
pkgdesc="An highly automated, intuitive, Digital Audio Workstation (DAW)"
arch=( 'x86_64' )
@@ -8,23 +8,29 @@ url='https://git.zrythm.org/zrythm/zrythm'
license=( 'GPL3' )
depends=('gtk3' 'lv2' 'lilv' 'libx11' 'jack'
'libsndfile' 'libyaml' 'gettext' 'qt5-base'
- 'libsamplerate' 'alsa-lib' 'ffmpeg' 'portaudio'
+ 'libsamplerate' 'alsa-lib' 'portaudio'
'ladspa' 'fftw')
-makedepends=('python' 'gettext' 'sed' 'libtool')
+makedepends=('python' 'gettext' 'sed'
+ 'meson' 'ninja')
conflicts=( 'zrythm-git' )
source=( "https://git.zrythm.org/zrythm/${pkgname}/-/archive/v$pkgver/${pkgname}-v$pkgver.tar.gz" )
-md5sums=( '5eebcbb84df1ad1d8c79f3fb94e87cec' )
+md5sums=( '0f54a1b6228373841078331dd345f25a' )
rootdir="${pkgname}-v${pkgver}"
build() {
cd ${rootdir}/
- autoreconf -fi
- ./configure --prefix=/usr --with-qt5 --with-ffmpeg
- make
+ mkdir -p build
+ cd build && meson --prefix=/usr .. -Denable_tests=true
+ ninja
+}
+
+check() {
+ cd ${rootdir}/
+ cd build && ninja test
}
package() {
cd ${rootdir}/
- make DESTDIR="${pkgdir}/" install
+ cd build && DESTDIR="${pkgdir}/" ninja install
}