summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-04-08 14:38:22 +0100
committerAlexandros Theodotou2019-04-08 14:38:22 +0100
commit820b976f076bb4c9ec7c186462104ea7619a5aa0 (patch)
tree6a045448eb6b8b1f485c6e72cc4c0297fdc944c6
parent0841644b19b0ea1937d8df19e729076bf14d45d6 (diff)
downloadaur-820b976f076bb4c9ec7c186462104ea7619a5aa0.tar.gz
bump
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f741c9d1b34..38f743bc1f2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zrythm
pkgdesc = An highly automated, intuitive, Digital Audio Workstation (DAW)
- pkgver = 0.3.006
+ pkgver = 0.3.029
pkgrel = 1
url = https://git.zrythm.org/zrythm/zrythm
arch = x86_64
@@ -17,11 +17,13 @@ pkgbase = zrythm
depends = libsndfile
depends = libyaml
depends = gettext
- depends = portaudio
+ depends = qt5-base
depends = libsamplerate
+ depends = alsa-lib
+ depends = ffmpeg
conflicts = zrythm-git
- source = https://git.zrythm.org/zrythm/zrythm/-/archive/v0.3.006/zrythm-v0.3.006.tar.gz
- md5sums = defb76859be0a2233a5e487e42753756
+ source = https://git.zrythm.org/zrythm/zrythm/-/archive/v0.3.029/zrythm-v0.3.029.tar.gz
+ md5sums = 9366c277c18bf391d44e29b2107c6b1a
pkgname = zrythm
diff --git a/PKGBUILD b/PKGBUILD
index 2befd0fd6955..9312869a2497 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
# Maintainer: Alexandros Theodotou <alex@zrythm.org>
pkgname=zrythm
-pkgver=0.3.006
+pkgver=0.3.029
pkgrel=1
pkgdesc="An highly automated, intuitive, Digital Audio Workstation (DAW)"
arch=( 'x86_64' )
url='https://git.zrythm.org/zrythm/zrythm'
license=( 'GPL3' )
-depends=('gtk3' 'lv2' 'lilv' 'libx11' 'jack' 'libsndfile' 'libyaml' 'gettext'
- 'portaudio' 'libsamplerate')
+depends=('gtk3' 'lv2' 'lilv' 'libx11' 'jack'
+ 'libsndfile' 'libyaml' 'gettext' 'qt5-base'
+ 'libsamplerate' 'alsa-lib' 'ffmpeg')
makedepends=('python' 'gettext' 'sed' 'libtool')
conflicts=( 'zrythm-git' )
source=( "https://git.zrythm.org/zrythm/${pkgname}/-/archive/v$pkgver/${pkgname}-v$pkgver.tar.gz" )
-md5sums=( 'defb76859be0a2233a5e487e42753756' )
+md5sums=( '9366c277c18bf391d44e29b2107c6b1a' )
rootdir="${pkgname}-v${pkgver}"
build() {
cd ${rootdir}/
autoreconf -fi
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --with-qt5 --with-ffmpeg
make
}