summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-03-06 07:56:41 +0000
committerAlexandros Theodotou2019-03-06 07:56:41 +0000
commitec1d1a40116471b25a195d7695ea77fc5c3e3850 (patch)
tree132a1d764cbf991042582a5cd26cd918119b4eff
parentb30a83197e21bba098549f521cbc4dc13d414365 (diff)
downloadaur-ec1d1a40116471b25a195d7695ea77fc5c3e3850.tar.gz
use release ver
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 33 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb84aabb9da2..662e8f02d37a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,25 @@
pkgbase = zrythm
- pkgdesc = Free GNU/Linux music production system (DAW)
- pkgver = master
- pkgrel = 3
+ pkgdesc = An highly automated, intuitive, Digital Audio Workstation (DAW)
+ pkgver = 0.1.009
+ pkgrel = 1
url = https://git.zrythm.org/zrythm/zrythm
arch = x86_64
license = GPL3
+ makedepends = python
depends = gtk3
depends = lv2
depends = lilv
+ depends = libx11
depends = jack
depends = libsndfile
- depends = libsmf
depends = libdazzle
depends = breeze-icons
+ depends = libyaml
depends = portaudio
- depends = ffmpeg
- source = zrythm-master::https://git.zrythm.org/zrythm/zrythm/-/archive/master/zrythm-master.tar.gz
- source = libcyaml::https://github.com/tlsa/libcyaml/archive/v0.1.0.tar.gz
- md5sums = SKIP
- md5sums = SKIP
+ depends = libsamplerate
+ conflicts = zrythm-git
+ source = https://git.zrythm.org/zrythm/zrythm/-/archive/v0.1.009/zrythm-v0.1.009.tar.gz
+ md5sums = 27902dfb379b831ad0c3a18c8ed133aa
pkgname = zrythm
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5bc2aa573e1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 3f405473164a..ccaeeb129497 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,28 @@
-# Maintainer: Alexandros Theodotou <alex at zrythm dot org>
-
+# Maintainer: Alexandros Theodotou <alex@zrythm.org>
pkgname=zrythm
-pkgver=master
-_pkgname="$pkgname-$pkgver"
-pkgrel=3
-pkgdesc="Free GNU/Linux music production system (DAW)"
-arch=('x86_64')
-url="https://git.zrythm.org/zrythm/zrythm"
-license=('GPL3')
-depends=('gtk3' 'lv2' 'lilv' 'jack' 'libsndfile' 'libsmf' 'libdazzle'
- 'breeze-icons' 'portaudio' 'ffmpeg')
-source=("$_pkgname::https://git.zrythm.org/zrythm/zrythm/-/archive/$pkgver/zrythm-$pkgver.tar.gz"
- "libcyaml::https://github.com/tlsa/libcyaml/archive/v0.1.0.tar.gz")
-md5sums=('SKIP'
- 'SKIP')
+pkgver=0.1.009
+pkgrel=1
+pkgdesc="An highly automated, intuitive, Digital Audio Workstation (DAW)"
+arch=( 'x86_64' )
+url='https://git.zrythm.org/zrythm/zrythm'
+license=( 'GPL3' )
+depends=('gtk3' 'lv2' 'lilv' 'libx11' 'jack' 'libsndfile' 'libdazzle' 'breeze-icons' 'libyaml'
+ 'portaudio' 'libsamplerate')
+makedepends=('python')
+conflicts=( 'zrythm-git' )
+source=( "https://git.zrythm.org/zrythm/${pkgname}/-/archive/v$pkgver/${pkgname}-v$pkgver.tar.gz" )
+md5sums=( '27902dfb379b831ad0c3a18c8ed133aa' )
-prepare() {
- cd "$srcdir/$_pkgname"
- cp -r $srcdir/libcyaml-0.1.0/* ./ext/libcyaml/
-}
+rootdir="${pkgname}-v${pkgver}"
build() {
- cd "$srcdir/$_pkgname"
+ cd ${rootdir}/
autoreconf -fi
- ./configure --prefix=/usr --enable-aur-build
- make
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "$srcdir/$_pkgname"
- make DESTDIR="$pkgdir/" install
+ cd ${rootdir}/
+ make DESTDIR="${pkgdir}/" install
}