diff options
author | Alexandros Theodotou | 2019-09-05 22:22:48 +0100 |
---|---|---|
committer | Alexandros Theodotou | 2019-09-05 22:22:48 +0100 |
commit | 2ae4e8d3a438ac981c1078cbdc5da8abb862ddc0 (patch) | |
tree | e50a0a29c22f58145e9020a475f0bf2ca7b5ac24 | |
parent | c27ae7134cab048c50fe8d8475b6b28baea1ba3d (diff) | |
download | aur-2ae4e8d3a438ac981c1078cbdc5da8abb862ddc0.tar.gz |
move some dependencies to makedepends
-rw-r--r-- | .SRCINFO | 9 | ||||
-rw-r--r-- | PKGBUILD | 28 |
2 files changed, 18 insertions, 19 deletions
@@ -1,8 +1,8 @@ pkgbase = zrythm-git pkgdesc = a highly automated and intuitive digital audio workstation - pkgver = 0.6.175 + pkgver = 0.6.261 pkgrel = 1 - url = https://git.zrythm.org/zrythm/zrythm + url = https://www.zrythm.org arch = x86_64 arch = i686 license = AGPL3 @@ -13,17 +13,16 @@ pkgbase = zrythm-git makedepends = ninja makedepends = help2man makedepends = python-sphinx + makedepends = ladspa + makedepends = lv2 depends = gtk3 - depends = lv2 depends = lilv depends = libx11 depends = jack depends = libsndfile depends = libyaml - depends = gettext depends = libsamplerate depends = alsa-lib - depends = ladspa depends = fftw optdepends = portaudio: portaudio backend optdepends = qt5-base: for embedding qt5 plugin UIs @@ -1,18 +1,18 @@ # Maintainer: Alexandros Theodotou <alex@zrythm.org> _pkgname=zrythm pkgname=$_pkgname-git -pkgver=0.6.175 +pkgver=0.6.261 pkgrel=1 pkgdesc='a highly automated and intuitive digital audio workstation' arch=('x86_64' 'i686') -url='https://git.zrythm.org/zrythm/zrythm' +url="https://www.zrythm.org" license=('AGPL3') -depends=('gtk3' 'lv2' 'lilv' 'libx11' 'jack' - 'libsndfile' 'libyaml' 'gettext' - 'libsamplerate' 'alsa-lib' - 'ladspa' 'fftw') -makedepends=('python' 'gettext' 'sed' - 'meson' 'ninja' 'help2man' 'python-sphinx') +depends=('gtk3' 'lilv' 'libx11' 'jack' 'libsndfile' + 'libyaml' 'libsamplerate' 'alsa-lib' 'fftw') +makedepends=( + 'python' 'gettext' 'sed' + 'meson' 'ninja' 'help2man' 'python-sphinx' + 'ladspa' 'lv2') optdepends=('portaudio: portaudio backend' 'qt5-base: for embedding qt5 plugin UIs') conflicts=("$_pkgname") @@ -28,18 +28,18 @@ pkgver () { build() { cd "$srcdir/$_pkgname" - mkdir -p build - cd build && meson --prefix=/usr .. -Denable_tests=true -Duser_manual=true -Dmanpage=true - ninja + meson build --prefix=/usr -Denable_tests=true -Duser_manual=true -Dmanpage=true + ninja -C build } check() { cd "$srcdir/$_pkgname" - cd build && ninja test + ninja -C build test } package() { cd "$srcdir/$_pkgname" - install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${_pkgname}/COPYING" - cd build && DESTDIR="${pkgdir}/" ninja install + install -vDm 644 AUTHORS CONTRIBUTING.md CHANGELOG.md README.md THANKS TRANSLATORS \ + -t "${pkgdir}/usr/share/doc/${pkgname}/" + DESTDIR="${pkgdir}/" ninja -C build install } |