summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-02-17 03:56:38 +0000
committerAlexandros Theodotou2019-02-17 03:56:38 +0000
commit5755d8a0141357b1c610d7dbb8894b497c578020 (patch)
tree3f5d59dccb369161c15bca57e81cf88e301d5294
parent3fc66d81cdec5a3b135ce00357540ca1f90a5b9a (diff)
downloadaur-5755d8a0141357b1c610d7dbb8894b497c578020.tar.gz
use submodules for suil/libcyaml
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c69127b1462..34c07d3b5fc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zrythm-git
pkgdesc = Free GNU/Linux music production system (DAW)
- pkgver = r238.b2e559f
+ pkgver = r251.a51f070
pkgrel = 1
url = https://git.zrythm.org/zrythm/zrythm
arch = x86_64
@@ -21,6 +21,10 @@ pkgbase = zrythm-git
provides = zrythm
conflicts = zrythm
source = zrythm::git+https://git.zrythm.org/zrythm/zrythm.git
+ source = git+https://github.com/tlsa/libcyaml.git
+ source = git+https://git.zrythm.org/zrythm/suil.git
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = zrythm-git
diff --git a/PKGBUILD b/PKGBUILD
index 64e5272658f9..32273f9a02b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=zrythm
pkgname=$_pkgname-git
-pkgver=r238.b2e559f
+pkgver=r252.3b11bc9
pkgrel=1
pkgdesc="Free GNU/Linux music production system (DAW)"
arch=('x86_64')
@@ -13,8 +13,12 @@ conflicts=("$_pkgname")
depends=('gtk3' 'lv2' 'lilv' 'suil' 'jack' 'libsndfile' 'libsmf' 'libdazzle' 'breeze-icons'
'libcyaml' 'portaudio' 'ffmpeg')
makedepends=('git')
-source=("$_pkgname::git+https://git.zrythm.org/zrythm/zrythm.git")
-md5sums=('SKIP')
+source=("$_pkgname::git+https://git.zrythm.org/zrythm/zrythm.git"
+ "git+https://github.com/tlsa/libcyaml.git"
+ "git+https://git.zrythm.org/zrythm/suil.git")
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver () {
cd "$srcdir/$_pkgname"
@@ -23,9 +27,10 @@ pkgver () {
prepare() {
cd "$srcdir/$_pkgname"
- #git submodule init
- #git config submodule."ext/breeze-icons".url "$srcdir/breeze-icons"
- #git submodule update
+ git submodule init
+ git config submodule."ext/libcyaml".url "$srcdir/libcyaml"
+ git config submodule."ext/suil".url "$srcdir/suil"
+ git submodule update
}
build() {