summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralextee2018-11-18 02:16:38 +0000
committeralextee2018-11-18 02:16:38 +0000
commit822972525c90f9c6024c2c615ea3f5e6ea595bed (patch)
tree13d7e54c6d002b23798319ecb8b74f375738d36f
downloadaur-822972525c90f9c6024c2c615ea3f5e6ea595bed.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cc1eb929bf0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = zrythm-git
+ pkgdesc = Free GNU/Linux music production system (DAW)
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://gitlab.com/alextee/zrythm
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = gtk3
+ depends = lilv-git
+ depends = suil-git
+ depends = jack2
+ depends = libsndfile
+ depends = libsmf
+ source = zrythm-git-0.1::git+https://gitlab.com/alextee/zrythm.git
+ md5sums = SKIP
+
+pkgname = zrythm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e0d3bcc95d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Alexandros Theodotou <alex at alextee dot online>
+
+pkgname=zrythm-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="Free GNU/Linux music production system (DAW)"
+arch=('x86_64')
+url="https://gitlab.com/alextee/zrythm"
+license=('GPL')
+depends=('gtk3' 'lilv-git' 'suil-git' 'jack2' 'libsndfile' 'libsmf')
+makedepends=('git')
+source=("$pkgname-$pkgver::git+https://gitlab.com/alextee/zrythm.git")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ autoreconf -f
+ ./configure --prefix=/usr --enable-aur-build
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+