summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-03-05 18:19:05 +0000
committerAlexandros Theodotou2019-03-05 18:19:05 +0000
commitb34f05eb40177753a2572bb0a008d6de3b196ebe (patch)
tree87f38711bf0c44513981ce5868356cec5dbe9eec
parent58ad5dbd7fa7a6dceec07cbc81bf2014899fc8b0 (diff)
downloadaur-b34f05eb40177753a2572bb0a008d6de3b196ebe.tar.gz
add libyaml
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f87e231d4dd7..26504d085b12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,12 +15,10 @@ pkgbase = zrythm-git
depends = libdazzle
depends = breeze-icons
depends = portaudio
- depends = ffmpeg
+ depends = libyaml
provides = zrythm
conflicts = zrythm
source = zrythm::git+https://git.zrythm.org/zrythm/zrythm.git
- source = git+https://github.com/tlsa/libcyaml.git
- md5sums = SKIP
md5sums = SKIP
pkgname = zrythm-git
diff --git a/PKGBUILD b/PKGBUILD
index 45eb2c2d4aef..83d6de3362b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,12 +11,10 @@ license=('GPL3')
provides=("$_pkgname")
conflicts=("$_pkgname")
depends=('gtk3' 'lv2' 'lilv' 'jack' 'libsndfile' 'libsmf' 'libdazzle' 'breeze-icons'
- 'portaudio' 'ffmpeg')
+ 'portaudio' 'libyaml')
makedepends=('git')
-source=("$_pkgname::git+https://git.zrythm.org/zrythm/zrythm.git"
- "git+https://github.com/tlsa/libcyaml.git")
-md5sums=('SKIP'
- 'SKIP')
+source=("$_pkgname::git+https://git.zrythm.org/zrythm/zrythm.git")
+md5sums=('SKIP')
pkgver () {
cd "$srcdir/$_pkgname"
@@ -33,7 +31,7 @@ prepare() {
build() {
cd "$srcdir/$_pkgname"
autoreconf -fi
- ./configure --prefix=/usr --with-ffmpeg
+ ./configure --prefix=/usr
make
}