summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElijah Gregg2021-07-10 06:48:40 -0600
committerElijah Gregg2021-07-10 06:48:40 -0600
commitba9099752d8278ad242c92a91e6e242882b1ad99 (patch)
tree581ebbc2230d36484627e104c9bf0504ae6d5fc2
parenta3750610f5b07c327f9a03c6e76585ba9d0dac26 (diff)
downloadaur-ba9099752d8278ad242c92a91e6e242882b1ad99.tar.gz
Add missing dependencies, increment version number
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8792868714f6..02388c5b847e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zrythm-git
pkgdesc = a highly automated and intuitive digital audio workstation
- pkgver = 1.0.0.alpha.16.1.1.r.gd35c6dd55
+ pkgver = 1.0.0.alpha.19.0.1.r.gd60687b8e
pkgrel = 1
url = https://www.zrythm.org
arch = x86_64
@@ -18,6 +18,7 @@ pkgbase = zrythm-git
makedepends = ladspa
makedepends = lv2
makedepends = gtksourceview3
+ makedepends = cmake
depends = gtk3
depends = lilv
depends = libx11
@@ -34,6 +35,7 @@ pkgbase = zrythm-git
depends = python-sphinx-furo
depends = python-sphinx-copybutton
depends = python-sphinxcontrib-svg2pdfconverter
+ depends = xxhash
optdepends = portaudio: portaudio backend
optdepends = qt5-base: for embedding qt5 plugin UIs
provides = zrythm
@@ -42,4 +44,3 @@ pkgbase = zrythm-git
md5sums = SKIP
pkgname = zrythm-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 749104e4838f..25aca003b8bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
# Contributor: Alexandros Theodotou <alex@zrythm.org>
_pkgname=zrythm
pkgname=$_pkgname-git
-pkgver=1.0.0.alpha.16.1.1.r.gd35c6dd55
+pkgver=1.0.0.alpha.19.0.1.r.gd60687b8e
pkgrel=1
pkgdesc='a highly automated and intuitive digital audio workstation'
arch=('x86_64' 'i686')
url="https://www.zrythm.org"
license=('AGPL3')
depends=('gtk3' 'lilv' 'libx11' 'jack' 'libsndfile' 'libyaml' 'libsamplerate' 'alsa-lib' 'fftw'
- 'suil' 'breeze-icons' 'lv2' 'rubberband' 'python-sphinx-furo' 'python-sphinx-copybutton' 'python-sphinxcontrib-svg2pdfconverter')
+ 'suil' 'breeze-icons' 'lv2' 'rubberband' 'python-sphinx-furo' 'python-sphinx-copybutton' 'python-sphinxcontrib-svg2pdfconverter'
+ 'xxhash')
makedepends=('ruby-sass' 'python' 'gettext' 'sed' 'python-sphinx-intl'
'meson' 'ninja' 'help2man' 'python-sphinx'
- 'ladspa' 'lv2' 'gtksourceview3')
+ 'ladspa' 'lv2' 'gtksourceview3' 'cmake')
optdepends=('portaudio: portaudio backend'
'qt5-base: for embedding qt5 plugin UIs')
conflicts=("$_pkgname")