summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralextee2019-01-01 14:24:36 +0000
committeralextee2019-01-01 14:24:36 +0000
commitbd4d103636b813525cf330e5fde4b261d048dcb4 (patch)
tree1a7885265df6015c57a8d3e49b53f9aaff4625ab
parente51effc50b6a337f1fa9f6b0046ca4dde78d7da3 (diff)
downloadaur-bd4d103636b813525cf330e5fde4b261d048dcb4.tar.gz
use tarball instead of git
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c48725016716..d1742a2f622d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = zrythm-git
pkgdesc = Free GNU/Linux music production system (DAW)
- pkgver = 0.1
- pkgrel = 2
+ pkgver = master
+ pkgrel = 3
url = https://gitlab.com/alextee/zrythm
arch = x86_64
license = GPL
- makedepends = git
depends = gtk3
depends = lv2
depends = lilv-git
@@ -13,7 +12,7 @@ pkgbase = zrythm-git
depends = jack
depends = libsndfile
depends = libsmf
- source = zrythm-git-0.1::git+https://gitlab.com/alextee/zrythm.git
+ source = https://gitlab.com/alextee/zrythm/-/archive/master/zrythm-master.tar.gz
md5sums = SKIP
pkgname = zrythm-git
diff --git a/PKGBUILD b/PKGBUILD
index e8fa406a70e0..73996f81420d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,29 @@
# Maintainer: Alexandros Theodotou <alex at alextee dot online>
pkgname=zrythm-git
-pkgver=0.1
-pkgrel=2
+pkgver=master
+pkgrel=3
pkgdesc="Free GNU/Linux music production system (DAW)"
arch=('x86_64')
url="https://gitlab.com/alextee/zrythm"
license=('GPL')
depends=('gtk3' 'lv2' 'lilv-git' 'suil-git' 'jack' 'libsndfile' 'libsmf')
-makedepends=('git')
-source=("$pkgname-$pkgver::git+https://gitlab.com/alextee/zrythm.git")
+source=("https://gitlab.com/alextee/zrythm/-/archive/$pkgver/zrythm-$pkgver.tar.gz")
md5sums=('SKIP')
prepare() {
- cd "$pkgname-$pkgver"
+ cd "zrythm-$pkgver"
}
build() {
- cd "$pkgname-$pkgver"
+ cd "zrythm-$pkgver"
autoreconf -fi
./configure --prefix=/usr --enable-aur-build
make
}
package() {
- cd "$pkgname-$pkgver"
+ cd "zrythm-$pkgver"
make DESTDIR="$pkgdir/" install
}