summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-08-19 13:47:27 +0100
committerAlexandros Theodotou2019-08-19 13:47:27 +0100
commiteac86b3f970e10c7ce934ab5d62a62c940ef3855 (patch)
tree38f0f0d7acfa5cdc54e00741ca9a1d46885738d7
parent5f9945e6e71abe07c52acce561732fc831c5f84d (diff)
downloadaur-eac86b3f970e10c7ce934ab5d62a62c940ef3855.tar.gz
generate and install manpage and docs
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64a7d4528cb6..67ae95435f82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zrythm-git
pkgdesc = An highly automated, intuitive, Digital Audio Workstation (DAW)
- pkgver = 0.6.003.r5.g2c5ff65c
+ pkgver = 0.6.003.r24.g501ba444
pkgrel = 1
url = https://git.zrythm.org/zrythm/zrythm
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = zrythm-git
makedepends = meson
makedepends = ninja
makedepends = help2man
+ makedepends = python-sphinx
depends = gtk3
depends = lv2
depends = lilv
diff --git a/PKGBUILD b/PKGBUILD
index 46252eee41b1..1e5ae9f92039 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexandros Theodotou <alex@zrythm.org>
_pkgname=zrythm
pkgname=$_pkgname-git
-pkgver=0.6.003.r5.g2c5ff65c
+pkgver=0.6.003.r24.g501ba444
pkgrel=1
pkgdesc='An highly automated, intuitive, Digital Audio Workstation (DAW)'
arch=('x86_64' 'i686')
@@ -12,7 +12,7 @@ depends=('gtk3' 'lv2' 'lilv' 'libx11' 'jack'
'libsamplerate' 'alsa-lib'
'ladspa' 'fftw')
makedepends=('python' 'gettext' 'sed'
- 'meson' 'ninja' 'help2man')
+ 'meson' 'ninja' 'help2man' 'python-sphinx')
optdepends=('portaudio: portaudio backend'
'qt5-base: for embedding qt5 plugin UIs')
conflicts=("$_pkgname")
@@ -29,7 +29,7 @@ pkgver () {
build() {
cd "$srcdir/$_pkgname"
mkdir -p build
- cd build && meson --prefix=/usr .. -Denable_tests=true
+ cd build && meson --prefix=/usr .. -Denable_tests=true -Duser_manual=true -Dmanpage=true
ninja
}