summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorns2021-06-27 12:20:49 +0200
committerns2021-06-27 12:20:49 +0200
commit513a62cd8768773ed7ba0b7c3cf0a4ddadd7d3f7 (patch)
tree6940db4319e8e1e272bb6deec42cb6f2a0fa891d
downloadaur-513a62cd8768773ed7ba0b7c3cf0a4ddadd7d3f7.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--50-oryx.rules8
-rw-r--r--50-wally.rules10
-rw-r--r--PKGBUILD22
-rw-r--r--license.md9
-rw-r--r--zsa-udev.install12
7 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a93a23c10822
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = zsa-udev
+ pkgdesc = udev rules allowing Wally and Live Training use with ZSA keyboards
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/zsa/wally/wiki/Linux-install
+ install = zsa-udev.install
+ arch = any
+ license = MIT
+ depends = udev
+ source = https://raw.githubusercontent.com/zsa/wally/master/license.md
+ source = 50-oryx.rules
+ source = 50-wally.rules
+ sha256sums = d2841d63f4e0bdfda102390ab1ca09136230d22f88538863b24b0c7fc68e548e
+ sha256sums = 1775109f94073f4be019beca1db86b09f9be87a822726885eb588a7641c13e15
+ sha256sums = 8f2b5019ef59005c3562e02ece5e7a8e2437cf20af01f8daf1ef38337fea1042
+
+pkgname = zsa-udev
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8e6e8830548d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/src
+/pkg
+zsa-udev-*.pkg.tar.zst
diff --git a/50-oryx.rules b/50-oryx.rules
new file mode 100644
index 000000000000..4d4cb4c86911
--- /dev/null
+++ b/50-oryx.rules
@@ -0,0 +1,8 @@
+# Rule for all ZSA keyboards
+SUBSYSTEM=="usb", ATTR{idVendor}=="3297", GROUP="plugdev"
+# Rule for the Moonlander
+SUBSYSTEM=="usb", ATTR{idVendor}=="3297", ATTR{idProduct}=="1969", GROUP="plugdev"
+# Rule for the Ergodox EZ
+SUBSYSTEM=="usb", ATTR{idVendor}=="feed", ATTR{idProduct}=="1307", GROUP="plugdev"
+# Rule for the Planck EZ
+SUBSYSTEM=="usb", ATTR{idVendor}=="feed", ATTR{idProduct}=="6060", GROUP="plugdev"
diff --git a/50-wally.rules b/50-wally.rules
new file mode 100644
index 000000000000..f62f55a48414
--- /dev/null
+++ b/50-wally.rules
@@ -0,0 +1,10 @@
+# Teensy rules for the Ergodox EZ
+ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", ENV{ID_MM_DEVICE_IGNORE}="1"
+ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789A]?", ENV{MTP_NO_PROBE}="1"
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789ABCD]?", MODE:="0666"
+KERNEL=="ttyACM*", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", MODE:="0666"
+
+# STM32 rules for the Moonlander and Planck EZ
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="0483", ATTRS{idProduct}=="df11", \
+ MODE:="0666", \
+ SYMLINK+="stm32_dfu"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d027a4c4c332
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: ns <arch@xnia.org>
+pkgname=zsa-udev
+pkgver=1
+pkgrel=1
+pkgdesc="udev rules allowing Wally and Live Training use with ZSA keyboards"
+arch=('any')
+url='https://github.com/zsa/wally/wiki/Linux-install'
+license=('MIT')
+depends=(udev)
+install='zsa-udev.install'
+source=('https://raw.githubusercontent.com/zsa/wally/master/license.md'
+ '50-oryx.rules'
+ '50-wally.rules')
+sha256sums=('d2841d63f4e0bdfda102390ab1ca09136230d22f88538863b24b0c7fc68e548e'
+ '1775109f94073f4be019beca1db86b09f9be87a822726885eb588a7641c13e15'
+ '8f2b5019ef59005c3562e02ece5e7a8e2437cf20af01f8daf1ef38337fea1042')
+
+package() {
+ install -Dm 644 {"$srcdir","$pkgdir"/usr/share/licenses/zsa-udev}/license.md
+ install -Dm 644 {"$srcdir","$pkgdir"/usr/lib/udev/rules.d}/50-oryx.rules
+ install -Dm 644 {"$srcdir","$pkgdir"/usr/lib/udev/rules.d}/50-wally.rules
+}
diff --git a/license.md b/license.md
new file mode 100644
index 000000000000..45bbd402c83a
--- /dev/null
+++ b/license.md
@@ -0,0 +1,9 @@
+## License (MIT)
+
+Copyright 2019-2020, ZSA Technology Labs Inc.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/zsa-udev.install b/zsa-udev.install
new file mode 100644
index 000000000000..66d9139f7900
--- /dev/null
+++ b/zsa-udev.install
@@ -0,0 +1,12 @@
+post_install() {
+ udevadm trigger
+ udevadm control --reload-rules
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}