summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wiesner2021-03-27 18:34:37 +0100
committerSebastian Wiesner2021-03-27 18:34:37 +0100
commit52fbeb60b82e5eeaf155796404c020dbac98b952 (patch)
tree2f5acc1457ad181a27bf941f8645f4955be17d09
parent13628626af7c143c2fd9c1f53a4915c28fd95a82 (diff)
downloadaur-52fbeb60b82e5eeaf155796404c020dbac98b952.tar.gz
Pass modcacherw to make GOPATH writable
See https://aur.archlinux.org/packages/zsa-wally/#comment-798794
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 735170e1f4b8..6fe2b95ee86f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,7 +31,7 @@ prepare() {
patch --strip=1 --input="$srcdir/desktop-file.patch"
export GOPATH="$srcdir/gopath"
- go get -u github.com/wailsapp/wails/cmd/wails@v1.8.0
+ go get -modcacherw -u github.com/wailsapp/wails/cmd/wails@v1.8.0
}
build() {
@@ -44,7 +44,7 @@ build() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath"
+ export GOFLAGS="-buildmode=pie -trimpath -modcacherw"
# Don't know what this does but it's in the install.linux.sh script from upstream
export CGO_ENABLED=1