summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Patrick Fair2020-08-28 08:37:26 -0600
committerChristopher Patrick Fair2020-08-28 08:37:26 -0600
commita485fa61313dd78bdff894ddcf02b3efe3c83377 (patch)
tree11f848221ddfd0cf99be95b6b56e1fbb0332b7f4
parent3894661fd2fbed2d68628a06d18bcdd2a8c6d62a (diff)
downloadaur-a485fa61313dd78bdff894ddcf02b3efe3c83377.tar.gz
Upgraded to wally version 2.0.0 which now must be built manually as the
download directory is no longer storing current updates. This is a wails app so I added the ability to pull the most recent version of wails to do the build.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a6d69e8d4aa..b4aa094d9dba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zsa-wally
pkgdesc = Wally: Flash your ZSA Keyboard the EZ way.
- pkgver = 1.1.1
- pkgrel = 2
+ pkgver = 2.0.0
+ pkgrel = 1
url = https://github.com/zsa/wally
arch = i686
arch = x86_64
@@ -10,10 +10,9 @@ pkgbase = zsa-wally
depends = webkit2gtk
depends = libusb
provides = wally
- source = https://github.com/zsa/wally/releases/download/1.1.1-linux/wally
+ source = https://github.com/zsa/wally/releases/download/2.0.0-linux/wally
source = 50-wally.rules
- sha256sums = ef3c743bb3d15f6f5b01f6cddd189a4761be12175d63e852651dbb6653e21d0f
- sha256sums = SKIP
+ sha256sums = 9dd7dc0b62e3b8ae15684cb10995a8ff04e285ef0bf1a61069040bd7c5c13683 sha256sums = SKIP
pkgname = zsa-wally
diff --git a/PKGBUILD b/PKGBUILD
index aa622056ff69..9abf0a2142d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,30 @@
# Maintainer: Jiří Prokop <jprokop@synaptiko.cz>
pkgname=zsa-wally
-pkgver=1.1.1
-pkgrel=2
+pkgver=2.0.0
+pkgrel=1
pkgdesc="Wally: Flash your ZSA Keyboard the EZ way."
arch=('i686' 'x86_64')
url="https://github.com/zsa/wally"
license=('MIT')
depends=('gtk3' 'webkit2gtk' 'libusb')
provides=('wally')
-source=('https://github.com/zsa/wally/releases/download/1.1.1-linux/wally'
- '50-wally.rules'
+source=("https://github.com/zsa/wally/archive/${pkgver}-linux.tar.gz"
+ "50-wally.rules"
)
-sha256sums=('ef3c743bb3d15f6f5b01f6cddd189a4761be12175d63e852651dbb6653e21d0f'
+sha256sums=('9dd7dc0b62e3b8ae15684cb10995a8ff04e285ef0bf1a61069040bd7c5c13683'
'SKIP'
)
+build() {
+ export GOPATH="$srcdir"/gopath
+ cd "$srcdir/wally-$pkgver-linux"
+ go get -u github.com/wailsapp/wails/cmd/wails
+ wails build
+}
+
+
package() {
install -Dm644 50-wally.rules "$pkgdir"/etc/udev/rules.d/50-wally.rules
- install -Dm755 wally "$pkgdir"/usr/bin/wally
+ install -Dm755 $srcdir/wally-$pkgver-linux/build/wally "$pkgdir"/usr/bin/wally
}