summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrett Cornwall2021-03-24 21:38:12 -0700
committerBrett Cornwall2021-03-24 21:38:12 -0700
commit2475afc3b72d2bde95b24e22afd53bc75053df0c (patch)
tree3c8f76ade07a150b0dca544bdb2577174c1800c8
downloadaur-2475afc3b72d2bde95b24e22afd53bc75053df0c.tar.gz
import from zsa-wally
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD30
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7082b198f0ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = zsa-wally
+ pkgdesc = Wally: Flash your ZSA Keyboard the EZ way.
+ pkgver = 2.1.0
+ pkgrel = 10
+ url = https://github.com/zsa/wally
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = gtk3
+ depends = webkit2gtk
+ depends = libusb
+ provides = wally
+ source = https://github.com/zsa/wally/releases/download/2.1.0-linux/wally
+ source = https://github.com/zsa/wally/raw/2.1.0-linux/appicon.png
+ source = https://github.com/zsa/wally/raw/2.1.0-linux/dist/linux64/50-wally.rules
+ source = https://github.com/zsa/wally/raw/2.1.0-linux/dist/linux64/wally.desktop
+ sha256sums = cdb168899d4e3a81eddfcfa7746d1e4e0dab886ea043644e54339b51f396c087
+ sha256sums = 81df9f24859cfd19ee8128d74a72155fe222e33349c9a647da98922f3f5b7857
+ sha256sums = 269c9196bc65b2e62be549e3d34e56768fe702ff099b7780a1661ca4c92a0143
+ sha256sums = d769c63305a6a4f5aa1d661826d8c475014ef8b456e60074596e940e7901c130
+
+pkgname = zsa-wally
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e955b5114df3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+zsa-wally-*.pkg.tar.zst
+wally
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33a4a96d4de5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Christopher Fair <christopherpfair@comcast.net>
+
+pkgname=zsa-wally-bin
+pkgver=2.1.0
+pkgrel=10
+srcRepo="https://github.com/zsa/wally/raw/${pkgver}-linux"
+srcRepoExp="${srcRepo}/dist/linux64"
+pkgdesc="Wally: Flash your ZSA Keyboard the EZ way."
+arch=('i686' 'x86_64')
+url="https://github.com/zsa/wally"
+license=('MIT')
+depends=('gtk3' 'webkit2gtk' 'libusb')
+provides=('wally')
+source=("https://github.com/zsa/wally/releases/download/${pkgver}-linux/wally"
+ "${srcRepo}/appicon.png"
+ "${srcRepoExp}/50-wally.rules"
+ "${srcRepoExp}/wally.desktop"
+)
+sha256sums=('cdb168899d4e3a81eddfcfa7746d1e4e0dab886ea043644e54339b51f396c087'
+ '81df9f24859cfd19ee8128d74a72155fe222e33349c9a647da98922f3f5b7857'
+ '269c9196bc65b2e62be549e3d34e56768fe702ff099b7780a1661ca4c92a0143'
+ 'd769c63305a6a4f5aa1d661826d8c475014ef8b456e60074596e940e7901c130'
+ )
+
+package() {
+ install -Dm644 appicon.png "$pkgdir/usr/share/pixmaps/wally.png"
+ install -Dm755 wally "$pkgdir/usr/bin/wally"
+ install -Dm644 50-wally.rules "$pkgdir/etc/udev/rules.d/50-wally.rules"
+ install -Dm644 wally.desktop "$pkgdir/usr/share/applications/wally.desktop"
+}