summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorslimb2021-04-10 15:01:34 -0700
committerslimb2021-04-10 15:19:52 -0700
commita2383f4f234225f8a26a55ffc0e3dff87deda0bf (patch)
tree7f2cfab24d1c89a60712516c95aa84b158d69148
parent8539ef93b2e05f48e9c4a13b8a3877c910e298ab (diff)
downloadaur-a2383f4f234225f8a26a55ffc0e3dff87deda0bf.tar.gz
Bump pkgver; clean up PKGBUILD and standardize it a bit with zsa-wally
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD40
-rw-r--r--desktop.patch14
-rw-r--r--udev-rules.patch29
4 files changed, 86 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31aee90e3a89..379a640de360 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zsa-wally-bin
- pkgdesc = Wally: Flash your ZSA Keyboard the EZ way.
- pkgver = 2.1.0
- pkgrel = 10
+ pkgdesc = Flash your ZSA Keyboard the EZ way.
+ pkgver = 2.1.1
+ pkgrel = 1
url = https://github.com/zsa/wally
arch = i686
arch = x86_64
@@ -10,14 +10,23 @@ pkgbase = zsa-wally-bin
depends = webkit2gtk
depends = libusb
provides = wally
- source = https://github.com/zsa/wally/releases/download/2.1.0-linux/wally
- source = https://github.com/zsa/wally/raw/2.1.0-linux/appicon.png
- source = https://github.com/zsa/wally/raw/2.1.0-linux/dist/linux64/50-wally.rules
- source = https://github.com/zsa/wally/raw/2.1.0-linux/dist/linux64/wally.desktop
- sha256sums = cdb168899d4e3a81eddfcfa7746d1e4e0dab886ea043644e54339b51f396c087
+ conflicts = zsa-wally
+ source = https://github.com/zsa/wally/releases/download/2.1.1-linux/wally
+ source = https://github.com/zsa/wally/raw/2.1.1-linux/appicon.png
+ source = https://github.com/zsa/wally/raw/2.1.1-linux/license.md
+ source = https://github.com/zsa/wally/raw/2.1.1-linux/dist/linux64/50-wally.rules
+ source = https://github.com/zsa/wally/raw/2.1.1-linux/dist/linux64/50-oryx.rules
+ source = https://github.com/zsa/wally/raw/2.1.1-linux/dist/linux64/wally.desktop
+ source = udev-rules.patch
+ source = desktop.patch
+ sha256sums = f1cc556d91a9851f34e4280efffc536798b494191ef62b24ad248826916e445f
sha256sums = 81df9f24859cfd19ee8128d74a72155fe222e33349c9a647da98922f3f5b7857
+ sha256sums = d2841d63f4e0bdfda102390ab1ca09136230d22f88538863b24b0c7fc68e548e
sha256sums = 269c9196bc65b2e62be549e3d34e56768fe702ff099b7780a1661ca4c92a0143
+ sha256sums = 6c7d4d27745080269115c58c4c5d863b23c534635975f3bca581c52687721c52
sha256sums = d769c63305a6a4f5aa1d661826d8c475014ef8b456e60074596e940e7901c130
+ sha256sums = 122bd3a43cbdd395e73474979797eb7327364f3bec29f9e869f704e84da55e41
+ sha256sums = a0d79d48c932c4d6c02ce8e8802dff3e888b35cb996e10a981adb839aafc2afd
pkgname = zsa-wally-bin
diff --git a/PKGBUILD b/PKGBUILD
index 33a4a96d4de5..0f394d883809 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,42 @@
-# Maintainer: Christopher Fair <christopherpfair@comcast.net>
+# Maintainer: slimb
pkgname=zsa-wally-bin
-pkgver=2.1.0
-pkgrel=10
-srcRepo="https://github.com/zsa/wally/raw/${pkgver}-linux"
-srcRepoExp="${srcRepo}/dist/linux64"
-pkgdesc="Wally: Flash your ZSA Keyboard the EZ way."
+pkgver=2.1.1
+pkgrel=1
+pkgdesc='Flash your ZSA Keyboard the EZ way.'
arch=('i686' 'x86_64')
-url="https://github.com/zsa/wally"
+url='https://github.com/zsa/wally'
license=('MIT')
depends=('gtk3' 'webkit2gtk' 'libusb')
provides=('wally')
+conflicts=('zsa-wally')
source=("https://github.com/zsa/wally/releases/download/${pkgver}-linux/wally"
- "${srcRepo}/appicon.png"
- "${srcRepoExp}/50-wally.rules"
- "${srcRepoExp}/wally.desktop"
+ "https://github.com/zsa/wally/raw/${pkgver}-linux/appicon.png"
+ "https://github.com/zsa/wally/raw/${pkgver}-linux/license.md"
+ "https://github.com/zsa/wally/raw/${pkgver}-linux/dist/linux64/50-wally.rules"
+ "https://github.com/zsa/wally/raw/${pkgver}-linux/dist/linux64/50-oryx.rules"
+ "https://github.com/zsa/wally/raw/${pkgver}-linux/dist/linux64/wally.desktop"
+ 'udev-rules.patch'
+ 'desktop.patch'
)
-sha256sums=('cdb168899d4e3a81eddfcfa7746d1e4e0dab886ea043644e54339b51f396c087'
+sha256sums=('f1cc556d91a9851f34e4280efffc536798b494191ef62b24ad248826916e445f'
'81df9f24859cfd19ee8128d74a72155fe222e33349c9a647da98922f3f5b7857'
+ 'd2841d63f4e0bdfda102390ab1ca09136230d22f88538863b24b0c7fc68e548e'
'269c9196bc65b2e62be549e3d34e56768fe702ff099b7780a1661ca4c92a0143'
+ '6c7d4d27745080269115c58c4c5d863b23c534635975f3bca581c52687721c52'
'd769c63305a6a4f5aa1d661826d8c475014ef8b456e60074596e940e7901c130'
- )
+ '122bd3a43cbdd395e73474979797eb7327364f3bec29f9e869f704e84da55e41'
+ 'a0d79d48c932c4d6c02ce8e8802dff3e888b35cb996e10a981adb839aafc2afd')
+
+prepare() {
+ patch --follow-symlinks --input="$srcdir/udev-rules.patch"
+ patch --follow-symlinks --input="$srcdir/desktop.patch"
+}
package() {
- install -Dm644 appicon.png "$pkgdir/usr/share/pixmaps/wally.png"
install -Dm755 wally "$pkgdir/usr/bin/wally"
- install -Dm644 50-wally.rules "$pkgdir/etc/udev/rules.d/50-wally.rules"
+ install -Dm644 -t "$pkgdir/usr/lib/udev/rules.d/" 50-oryx.rules 50-wally.rules
install -Dm644 wally.desktop "$pkgdir/usr/share/applications/wally.desktop"
+ install -Dm644 appicon.png "$pkgdir/usr/share/pixmaps/wally.png"
+ install -Dm644 license.md "$pkgdir/usr/share/licenses/$pkgname/license.md"
}
diff --git a/desktop.patch b/desktop.patch
new file mode 100644
index 000000000000..7ebe0813be50
--- /dev/null
+++ b/desktop.patch
@@ -0,0 +1,14 @@
+--- a/wally.desktop
++++ b/wally.desktop
+@@ -2,9 +2,9 @@
+ Type=Application
+ Version=1.0
+ Name=Wally
+-Name[en_US]=Wally
++GenericName=ZSA Keyboard Flashing Tool
+ Comment=Flash your ZSA keyboard the EZ way
+ Exec=wally
+ Icon=wally
+ Terminal=false
+-Categories=Development;
++Categories=Settings;HardwareSettings;
diff --git a/udev-rules.patch b/udev-rules.patch
new file mode 100644
index 000000000000..bdf2c646568b
--- /dev/null
+++ b/udev-rules.patch
@@ -0,0 +1,29 @@
+--- a/50-wally.rules
++++ b/50-wally.rules
+@@ -1,10 +1,8 @@
+ # Teensy rules for the Ergodox EZ Original / Shine / Glow
+ ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", ENV{ID_MM_DEVICE_IGNORE}="1"
+ ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789A]?", ENV{MTP_NO_PROBE}="1"
+-SUBSYSTEMS=="usb", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789ABCD]?", MODE:="0666"
+-KERNEL=="ttyACM*", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", MODE:="0666"
++SUBSYSTEMS=="usb", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789ABCD]?", TAG+="uaccess"
++KERNEL=="ttyACM*", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", TAG+="uaccess"
+
+ # STM32 rules for the Moonlander and Planck EZ Standard / Glow
+-SUBSYSTEMS=="usb", ATTRS{idVendor}=="0483", ATTRS{idProduct}=="df11", \
+- MODE:="0666", \
+- SYMLINK+="stm32_dfu"
++SUBSYSTEMS=="usb", ATTRS{idVendor}=="0483", ATTRS{idProduct}=="df11", TAG+="uaccess", SYMLINK+="stm32_dfu"
+
+--- a/50-oryx.rules
++++ b/50-oryx.rules
+@@ -1,6 +1,6 @@
+ # Rule for the Moonlander
+-SUBSYSTEM=="usb", ATTR{idVendor}=="3297", ATTR{idProduct}=="1969", TAG+="uaccess", TAG+="udev-acl"
++SUBSYSTEM=="usb", ATTR{idVendor}=="3297", ATTR{idProduct}=="1969", TAG+="uaccess"
+ # Rule for the Ergodox EZ Original / Shine / Glow
+-SUBSYSTEM=="usb", ATTR{idVendor}=="feed", ATTR{idProduct}=="1307", TAG+="uaccess", TAG+="udev-acl"
++SUBSYSTEM=="usb", ATTR{idVendor}=="feed", ATTR{idProduct}=="1307", TAG+="uaccess"
+ # Rule for the Planck EZ Standard / Glow
+-SUBSYSTEM=="usb", ATTR{idVendor}=="feed", ATTR{idProduct}=="6060", TAG+="uaccess", TAG+="udev-acl"
++SUBSYSTEM=="usb", ATTR{idVendor}=="feed", ATTR{idProduct}=="6060", TAG+="uaccess"