summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFox Kiester2022-03-19 08:56:18 -0400
committerFox Kiester2022-03-19 09:23:40 -0400
commit6f51a9a50b4ff36a71a3a7aad441d5b81337bf2f (patch)
tree8a7374dfc0fdac5360c2d0a1acf7819df376c2d3
parent379c4c10ff4cfd2673a3f2b127da4ca770abcde6 (diff)
downloadaur-6f51a9a50b4ff36a71a3a7aad441d5b81337bf2f.tar.gz
Fix installation error
Github no longer allows unauthenticated git://. Use git over https. Also - Update pkgver and update pkgver function to consider non-annotated tags - Fix contact info
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1109bdc86b63..e522ac3ea78d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fox Kiester <noct[at]posteo[dot]net>
_pkgname=zscroll
pkgname=zscroll-git
-pkgver=0.1.r5.gd42dc2c
+pkgver=2.0.1.r0.g788be96
pkgrel=1
pkgdesc="A text scroller for use with panels"
arch=('any')
@@ -10,12 +10,12 @@ license=('GPL3')
depends=('python')
makedepends=('git')
provides=("${_pkgname}")
-source=("git://github.com/noctuid/${_pkgname}.git")
+source=("git+https://github.com/noctuid/${_pkgname}")
md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {