summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorseth2022-09-06 19:29:23 -0400
committerseth2022-09-06 19:29:23 -0400
commit36eb8876d70c00d18402f7054f01e06f5c948eac (patch)
tree2cd0a4887d71ebe629b00f8acc6c5f402e159ce4
parent8c17106005b93b2c85bd58b158d8906d8c363dbc (diff)
downloadaur-36eb8876d70c00d18402f7054f01e06f5c948eac.tar.gz
update to 1.6.4
-rw-r--r--.SRCINFO8
-rw-r--r--0001-no-self-updating.patch11
-rw-r--r--PKGBUILD6
3 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e595d161815d..bdcccb39a32a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zsh-antidote
pkgdesc = the cure to slow zsh plugin management
- pkgver = 1.6.3
+ pkgver = 1.6.4
pkgrel = 1
url = https://getantidote.github.io/
install = zsh-antidote.install
@@ -8,9 +8,9 @@ pkgbase = zsh-antidote
license = MIT
depends = zsh
depends = git
- source = antidote-1.6.3.tar.gz::https://github.com/mattmc3/antidote/archive/refs/tags/v1.6.3.tar.gz
+ source = antidote-1.6.4.tar.gz::https://github.com/mattmc3/antidote/archive/refs/tags/v1.6.4.tar.gz
source = 0001-no-self-updating.patch
- sha256sums = 1817ea319e1f95b655872876c55df35bf404ed671053b751a81750550ca03248
- sha256sums = 8dd03cfbfb9a838931e12ccf6da5ed6917e36fd873ff2fff25fbad63ff9d4265
+ sha256sums = 336ea89aab33d07d5d2eaa14af2f015d7da657837f64d3e76fa5c54645210950
+ sha256sums = dd4bad447383091b29e47add48394a00a459eb87cd2d76c5ea110fc261ed2785
pkgname = zsh-antidote
diff --git a/0001-no-self-updating.patch b/0001-no-self-updating.patch
index b219c1f6951d..c6f4bdbe6580 100644
--- a/0001-no-self-updating.patch
+++ b/0001-no-self-updating.patch
@@ -1,18 +1,17 @@
diff --git a/functions/antidote-update b/functions/antidote-update
-index aa8b5a1..200133a 100644
+index 0618841..c126295 100644
--- a/functions/antidote-update
+++ b/functions/antidote-update
-@@ -38,11 +38,8 @@ if (( $#o_bundles )) || ! (( $#o_self )); then
- fi
+@@ -40,11 +40,7 @@ fi
# update antidote
--if (( $#o_self )) || ! (( $#o_bundles )); then
+ if (( $#o_self )) || ! (( $#o_bundles )); then
- echo "Updating antidote..."
- git -C "${0:A:h:h}" pull --quiet --ff --rebase --autostash
+- echo "Antidote self-update complete.\n"
- source "${0:A:h:h}"/antidote.zsh
- antidote -v
-+if (( $#o_self )); then
-+ echo "Self updating is disabled in this build."
++ echo "Self updating is disabled in this build"
fi
# vim: ft=zsh
diff --git a/PKGBUILD b/PKGBUILD
index 0beff4f00247..92ba62157e84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=zsh-antidote
_pkgname=antidote
-pkgver=1.6.3
+pkgver=1.6.4
pkgrel=1
pkgdesc="the cure to slow zsh plugin management"
arch=(any)
@@ -14,8 +14,8 @@ source=(
"${_pkgname}-${pkgver}.tar.gz::https://github.com/mattmc3/antidote/archive/refs/tags/v${pkgver}.tar.gz"
"0001-no-self-updating.patch"
)
-sha256sums=('1817ea319e1f95b655872876c55df35bf404ed671053b751a81750550ca03248'
- '8dd03cfbfb9a838931e12ccf6da5ed6917e36fd873ff2fff25fbad63ff9d4265')
+sha256sums=('336ea89aab33d07d5d2eaa14af2f015d7da657837f64d3e76fa5c54645210950'
+ 'dd4bad447383091b29e47add48394a00a459eb87cd2d76c5ea110fc261ed2785')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"