summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorseth2022-08-22 17:25:44 -0400
committerseth2022-08-22 17:25:44 -0400
commit660db98beb09134aafb8ce4cbcc317cfb7670bfd (patch)
tree8025b0cd4718a00b400741f7d7b08269ef295e41
parente905c2b259b41a7083b2738e5e7862e0cf4561ea (diff)
downloadaur-660db98beb09134aafb8ce4cbcc317cfb7670bfd.tar.gz
update to 1.5.1
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD9
-rw-r--r--zsh-antidote.install8
4 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e9534dc5df9..3658d44a1498 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zsh-antidote
pkgdesc = the cure to slow zsh plugin management
- pkgver = 1.4.1
+ pkgver = 1.5.1
pkgrel = 1
url = https://getantidote.github.io/
install = zsh-antidote.install
@@ -8,9 +8,9 @@ pkgbase = zsh-antidote
license = MIT
depends = zsh
depends = git
- source = antidote-1.4.1.tar.gz::https://github.com/mattmc3/antidote/archive/refs/tags/v1.4.1.tar.gz
+ source = antidote-1.5.1.tar.gz::https://github.com/mattmc3/antidote/archive/refs/tags/v1.5.1.tar.gz
source = 0001-no-self-updating.patch
- sha256sums = b87804b55fb6a33aac4864d983b216f6fae3b0ccf26fa3d5ce3e8d123133fff8
+ sha256sums = 7951f6b8b2ac6386f5d75c531e3618deda6ad2e80737d49aa5888a84f1dd89c1
sha256sums = f45a3380864145f31ba1f9ce771f156f104e5b70dae1d1de46ba5177cdc4e88e
pkgname = zsh-antidote
diff --git a/.gitignore b/.gitignore
index 2f6b431988c9..6931c66c0c74 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
-*.tar*
+*.tar.*
*.log
pkg/
src/
+antidote/
diff --git a/PKGBUILD b/PKGBUILD
index 20c3becf0bc3..a04641643ef7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=zsh-antidote
_pkgname=antidote
-pkgver=1.4.1
+pkgver=1.5.1
pkgrel=1
pkgdesc="the cure to slow zsh plugin management"
arch=(any)
@@ -14,7 +14,7 @@ source=(
"${_pkgname}-${pkgver}.tar.gz::https://github.com/mattmc3/antidote/archive/refs/tags/v${pkgver}.tar.gz"
"0001-no-self-updating.patch"
)
-sha256sums=('b87804b55fb6a33aac4864d983b216f6fae3b0ccf26fa3d5ce3e8d123133fff8'
+sha256sums=('7951f6b8b2ac6386f5d75c531e3618deda6ad2e80737d49aa5888a84f1dd89c1'
'f45a3380864145f31ba1f9ce771f156f104e5b70dae1d1de46ba5177cdc4e88e')
prepare() {
@@ -26,8 +26,9 @@ prepare() {
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- install -Dm0644 -t "${pkgdir}/usr/share/${_pkgname}/" "${_pkgname}.zsh"
- cp -r functions/ "${pkgdir}/usr/share/${_pkgname}/"
+ install -Dm0644 -t "${pkgdir}/usr/share/${pkgname}/" "${_pkgname}.zsh"
+ cp -r functions/ "${pkgdir}/usr/share/${pkgname}/"
+ install -Dm0644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" LICENSE
}
# nvim: set ts=2 sw=2 et:
diff --git a/zsh-antidote.install b/zsh-antidote.install
index 60e8f099b987..5907616fdee5 100644
--- a/zsh-antidote.install
+++ b/zsh-antidote.install
@@ -1,13 +1,11 @@
function info() {
- antidote_dir="/usr/share/antidote"
+ antidote_dir='/usr/share/zsh-antidote'
echo "--------------------------------------------------"
echo "antidote has been installed to $antidote_dir"
echo "put this in your zshrc to use it!"
echo "
- source '/usr/share/antidote/antidote.zsh'
- [[ ! -f \"\$ZDOTDIR/.zsh_plugins.zsh\" ]] && \\
- antidote bundle < \"\$ZDOTDIR/.zsh_plugins.txt\" > \"\$ZDOTDIR/.zsh_plugins.zsh\"
- source \"\$ZDOTDIR/.zsh_plugins.zsh\"
+ source '"$antidote_dir"/antidote.zsh'
+ antidote load
"
echo "--------------------------------------------------"
}