summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDean Wallace2019-07-18 00:18:41 +0100
committerDean Wallace2019-07-18 00:18:41 +0100
commit7e1ffe7989e1f5bc58f87d2030b93742a7f0a2ce (patch)
tree8e404749f7c822cf803a01c0cf8ccc172325ff8c
downloadaur-7e1ffe7989e1f5bc58f87d2030b93742a7f0a2ce.tar.gz
first
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
-rw-r--r--zsh-auto-notify.install8
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0b58f15c5b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = zsh-auto-notify
+ pkgdesc = Zsh plugin that sends out a notification when a long running task has completed
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/MichaelAquilina/zsh-auto-notify
+ install = zsh-auto-notify.install
+ arch = any
+ license = GPL
+ depends = zsh
+ source = zsh-auto-notify-0.2.0.tar.gz::https://github.com/MichaelAquilina/zsh-auto-notify/archive/0.2.0.tar.gz
+ sha512sums = e790029e8175a1426ae374c635b40296917db55e71e3d5408a18c02cd1a2d8002a979494feaa3651d9488948a13ee13a3feab4cfe09f67a802408f0134c1550c
+
+pkgname = zsh-auto-notify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c8acef125df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: duffydack <duffydack73 {at] gmail {dot} com>
+pkgname=zsh-auto-notify
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Zsh plugin that sends out a notification when a long running task has completed"
+arch=('any')
+url="https://github.com/MichaelAquilina/zsh-auto-notify"
+license=('GPL')
+depends=('zsh')
+install=$pkgname.install
+source=("$pkgname-$pkgver.tar.gz::https://github.com/MichaelAquilina/${pkgname}/archive/${pkgver}.tar.gz")
+sha512sums=('e790029e8175a1426ae374c635b40296917db55e71e3d5408a18c02cd1a2d8002a979494feaa3651d9488948a13ee13a3feab4cfe09f67a802408f0134c1550c')
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -vDm 644 auto-notify.plugin.zsh \
+ -t "${pkgdir}/usr/share/zsh/plugins/${pkgname}/"
+ # docs
+ install -vDm 644 README.rst \
+ -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ # license
+ install -vDm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/zsh-auto-notify.install b/zsh-auto-notify.install
new file mode 100644
index 000000000000..f521064168ce
--- /dev/null
+++ b/zsh-auto-notify.install
@@ -0,0 +1,8 @@
+post_install() {
+ cat << EOF
+To activate zsh-auto-notify, add the following line at the end of ~/.zshrc:
+ source /usr/share/zsh/plugins/zsh-auto-notify/auto-notify.plugin.zsh
+EOF
+}
+
+# vim:set ts=2 sw=2 et: