summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Libert2023-11-13 12:05:06 +0100
committerBart Libert2023-11-13 12:05:06 +0100
commitf1c012082cc1c2d362a6f76a0acb6a604f37f086 (patch)
treea86005babd7a25f699fd3940497795136e41b9ef
parentf289b933d14e615b170301885721d28741aa7e11 (diff)
downloadaur-f1c012082cc1c2d362a6f76a0acb6a604f37f086.tar.gz
Add pre-commit config and .gitignore
-rw-r--r--.gitignore5
-rw-r--r--.pre-commit-config.yaml23
2 files changed, 28 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69d7a6de40f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!.pre-commit-config.yaml
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
new file mode 100644
index 000000000000..57e1469b64ab
--- /dev/null
+++ b/.pre-commit-config.yaml
@@ -0,0 +1,23 @@
+---
+repos:
+ - repo: https://github.com/pre-commit/pre-commit-hooks
+ rev: v4.4.0
+ hooks:
+ - id: check-added-large-files
+ - id: check-case-conflict
+ - id: check-vcs-permalinks
+ - id: destroyed-symlinks
+ - id: detect-private-key
+ - id: end-of-file-fixer
+ - id: mixed-line-ending
+ - id: trailing-whitespace
+ - repo: https://github.com/jumanjihouse/pre-commit-hooks
+ rev: 3.0.0
+ hooks:
+ - id: shellcheck
+ - repo: https://github.com/edlanglois/pkgbuild-hooks
+ rev: v0.2.0
+ hooks:
+ - id: srcinfo-fixer
+ - id: verify-srcinfo-checksums
+default_install_hook_types: [pre-commit, commit-msg]