summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Reuße2015-12-13 11:26:15 +0100
committerSebastian Reuße2015-12-13 11:31:06 +0100
commit2b53f2293f76728547d04a257521aef1174c465d (patch)
tree29d950782dfe3c3fa5b48b2e38079f6e76513a2b
downloadaur-2b53f2293f76728547d04a257521aef1174c465d.tar.gz
Init.
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD40
-rw-r--r--example-bindings.zsh13
-rw-r--r--zsh-autopair-git.install11
5 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d2a5e2ddcd6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Dec 13 10:31:06 UTC 2015
+pkgbase = zsh-autopair-git
+ pkgdesc = Auto-close and delete matching delimiters in Zsh
+ pkgver = r18.87c209e
+ pkgrel = 1
+ url = https://github.com/hlissner/zsh-autopair
+ install = zsh-autopair-git.install
+ arch = any
+ license = custom:MIT
+ makedepends = git
+ depends = zsh
+ provides = zsh-autopair
+ conflicts = zsh-autopair
+ source = git+https://github.com/hlissner/zsh-autopair
+ source = example-bindings.zsh
+ sha256sums = SKIP
+ sha256sums = a7578c06251333ef096e82bb06244ec5ebbb8fe8039343a7544966fb9a76c5d6
+
+pkgname = zsh-autopair-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..468cd87d3ce8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..941130d7036a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Sebastian Reuße <seb@wirrsal.net>
+pkgname=zsh-autopair-git
+_gitname=zsh-autopair
+pkgver=r18.87c209e
+pkgrel=1
+pkgdesc="Auto-close and delete matching delimiters in Zsh"
+arch=(any)
+url=https://github.com/hlissner/zsh-autopair
+license=(custom:MIT)
+depends=(zsh)
+makedepends=(git)
+provides=(zsh-autopair)
+conflicts=(zsh-autopair)
+source=(
+ git+https://github.com/hlissner/zsh-autopair
+ example-bindings.zsh
+)
+install=zsh-autopair-git.install
+sha256sums=(
+ SKIP
+ a7578c06251333ef096e82bb06244ec5ebbb8fe8039343a7544966fb9a76c5d6
+)
+
+
+pkgver() {
+ cd "$_gitname"
+ commit=$(git rev-list --count master)
+ hash=$(git rev-parse --short HEAD)
+ echo "r$commit.$hash"
+}
+
+package() {
+ cd "$_gitname"
+
+ install -Dm644 autopair.zsh "$pkgdir"/usr/share/zsh/plugins/"$_gitname"/autopair.zsh
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/"$_gitname"/README.md
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+
+ install -Dm644 "$startdir"/example-bindings.zsh "$pkgdir"/usr/share/zsh/plugins/"$_gitname"/example-bindings.zsh
+}
diff --git a/example-bindings.zsh b/example-bindings.zsh
new file mode 100644
index 000000000000..8f20b5600c92
--- /dev/null
+++ b/example-bindings.zsh
@@ -0,0 +1,13 @@
+bindkey '`' autopair-insert-or-skip
+bindkey '"' autopair-insert-or-skip
+bindkey "'" autopair-insert-or-skip
+
+bindkey '(' autopair-insert
+bindkey '[' autopair-insert
+bindkey '{' autopair-insert
+
+bindkey ')' autopair-skip
+bindkey ']' autopair-skip
+bindkey '}' autopair-skip
+
+bindkey '^?' autopair-delete
diff --git a/zsh-autopair-git.install b/zsh-autopair-git.install
new file mode 100644
index 000000000000..81abbbfdcb9d
--- /dev/null
+++ b/zsh-autopair-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ cat <<<"
+To use, source the library from your .zshrc:
+
+ source /usr/share/zsh/plugins/zsh-autopair/autopair.zsh
+
+The example key bindings are also found there:
+
+ source /usr/share/zsh/plugins/zsh-autopair/example-bindings.zsh
+"
+}