summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-07-14 01:12:14 -0500
committerLuis Martinez2022-07-14 01:12:37 -0500
commitefabb1037477c2d42d469921542890c9cd61ffe4 (patch)
treeb4031152fe9f8f21f66ace76d18d6b09f601823e
parent68189544588e58669a4314dcc7fd0089a9490fea (diff)
downloadaur-efabb1037477c2d42d469921542890c9cd61ffe4.tar.gz
packaging update
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD39
-rw-r--r--zsh-autopair.install (renamed from zsh-autopair-git.install)0
3 files changed, 23 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d672dc1af349..c5bc6b7714f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
-# Generated by mksrcinfo v8
-# Mon Feb 1 16:24:46 UTC 2016
pkgbase = zsh-autopair-git
pkgdesc = Auto-close and delete matching delimiters in Zsh
- pkgver = r32.86b6d0e
+ pkgver = 1.0.r1.g9d003fc
pkgrel = 1
url = https://github.com/hlissner/zsh-autopair
- install = zsh-autopair-git.install
+ install = zsh-autopair.install
arch = any
- license = custom:MIT
+ license = MIT
makedepends = git
depends = zsh
- provides = zsh-autopair
+ provides = zsh-autopair=1.0
conflicts = zsh-autopair
- source = git+https://github.com/hlissner/zsh-autopair
+ source = zsh-autopair::git+https://github.com/hlissner/zsh-autopair
sha256sums = SKIP
pkgname = zsh-autopair-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 51e96277739a..536bc4355da8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,29 @@
-# Maintainer: Sebastian Reuße <seb@wirrsal.net>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Sebastian Reuße <seb@wirrsal.net>
+
pkgname=zsh-autopair-git
-_gitname=zsh-autopair
-pkgver=r32.86b6d0e
+_name="${pkgname%-git}"
+pkgver=1.0.r1.g9d003fc
pkgrel=1
pkgdesc="Auto-close and delete matching delimiters in Zsh"
-arch=(any)
+arch=('any')
url=https://github.com/hlissner/zsh-autopair
-license=(custom:MIT)
-depends=(zsh)
-makedepends=(git)
-provides=(zsh-autopair)
-conflicts=(zsh-autopair)
-source=(git+https://github.com/hlissner/zsh-autopair)
-install=zsh-autopair-git.install
+license=('MIT')
+depends=('zsh')
+makedepends=('git')
+provides=("$_name=${pkgver%.r*}")
+conflicts=("$_name")
+source=("$_name::git+$url")
+install="$_name.install"
sha256sums=(SKIP)
-
pkgver() {
- cd "$_gitname"
- commit=$(git rev-list --count master)
- hash=$(git rev-parse --short HEAD)
- echo "r$commit.$hash"
+ git -C "$_name" describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
package() {
- cd "$_gitname"
-
- install -Dm644 autopair.zsh "$pkgdir"/usr/share/zsh/plugins/"$_gitname"/autopair.zsh
- install -Dm644 README.md "$pkgdir"/usr/share/doc/"$_gitname"/README.md
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ cd "$_name"
+ install -Dm644 autopair.zsh -t "$pkgdir/usr/share/zsh/plugins/$_name/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}
diff --git a/zsh-autopair-git.install b/zsh-autopair.install
index 2b7e21ddd4b6..2b7e21ddd4b6 100644
--- a/zsh-autopair-git.install
+++ b/zsh-autopair.install