summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Stubbs2015-09-02 13:52:03 +0100
committerAndrew Stubbs2015-09-02 13:52:03 +0100
commit1870ed26f6bbf4a1db91efb9fd3bcef1008ffa96 (patch)
treeecfc1b173d477a8410fb69f72ddacdf75584f559
downloadaur-1870ed26f6bbf4a1db91efb9fd3bcef1008ffa96.tar.gz
Initial package.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--zsh-autosuggestions.install8
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51da50dc7e27
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = zsh-autosuggestions-git
+ pkgdesc = Fish shell like fast/unobtrusive autosuggestions for zsh
+ pkgver = 0.2.1.86.cbaf7ce
+ pkgrel = 1
+ url = https://github.com/tarruda/zsh-autosuggestions
+ install = zsh-autosuggestions.install
+ arch = any
+ license = Custom:MIT
+ makedepends = git
+ depends = zsh
+ provides = zsh-autosuggestions
+ source = zsh-autosuggestions::git://github.com/tarruda/zsh-autosuggestions
+ sha256sums = SKIP
+
+pkgname = zsh-autosuggestions-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a925b583619
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+_name='zsh-autosuggestions'
+pkgname="${_name}-git"
+pkgver=0.2.1.86.cbaf7ce
+pkgrel=1
+pkgdesc='Fish shell like fast/unobtrusive autosuggestions for zsh'
+url='https://github.com/tarruda/zsh-autosuggestions'
+arch=('any')
+license=('Custom:MIT')
+depends=('zsh')
+makedepends=('git')
+provides=('zsh-autosuggestions')
+install="${_name}.install"
+source=("${_name}::${url//https/git}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ echo "0.2.1.$(git rev-list --count HEAD).$(git describe --always )"
+}
+
+package() {
+ cd "${srcdir}/${_name}"
+ install -d "${pkgdir}/usr/share/zsh/plugins/${_name}"
+ cp -a --no-preserve=ownership * "${pkgdir}/usr/share/zsh/plugins/${_name}"
+
+ # license
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
+}
diff --git a/zsh-autosuggestions.install b/zsh-autosuggestions.install
new file mode 100644
index 000000000000..a1ba6d262c2d
--- /dev/null
+++ b/zsh-autosuggestions.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "==> To use zsh autosuggestions, include the following snippet in your .zshrc:
+ source /usr/share/zsh/plugins/zsh-autosuggestions/zsh-autosuggestions.zsh
+ zle-line-init() {
+ zle autosuggest-start
+ }
+ zle -N zle-line-init"
+}