summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Stubbs2016-02-08 09:32:15 +0000
committerAndrew Stubbs2016-02-08 09:32:15 +0000
commit26fea6d5183e4d77a61a035ee29e3a854829ae56 (patch)
tree77cf2789d35ef2a015a2c421b247d5fcd9b8b207
parentf08a2817a49b4868b2c1eea20be9ba7f918f4bc1 (diff)
downloadaur-26fea6d5183e4d77a61a035ee29e3a854829ae56.tar.gz
Update for new install process.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
-rw-r--r--zsh-autosuggestions.install6
3 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 845b0704b93f..764f121a1cc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zsh-autosuggestions-git
pkgdesc = Fish shell like fast/unobtrusive autosuggestions for zsh
- pkgver = 0.2.1.92.7a00bfa
+ pkgver = 0.2.1.101.f154d25
pkgrel = 1
url = https://github.com/tarruda/zsh-autosuggestions
install = zsh-autosuggestions.install
diff --git a/PKGBUILD b/PKGBUILD
index 3d2121b9b910..ef6905c7f8a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name='zsh-autosuggestions'
pkgname="${_name}-git"
-pkgver=0.2.1.92.7a00bfa
+pkgver=0.2.1.101.f154d25
pkgrel=1
pkgdesc='Fish shell like fast/unobtrusive autosuggestions for zsh'
url='https://github.com/tarruda/zsh-autosuggestions'
@@ -21,8 +21,13 @@ pkgver() {
package() {
cd "${srcdir}/${_name}"
install -d "${pkgdir}/usr/share/zsh/plugins/${_name}"
- cp -a --no-preserve=ownership * "${pkgdir}/usr/share/zsh/plugins/${_name}"
+ cp -a --no-preserve=ownership dist/autosuggestions.zsh "${pkgdir}/usr/share/zsh/plugins/${_name}"
# license
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
}
+
+#check() {
+# cd "${srcdir}/${_name}"
+# make test
+#}
diff --git a/zsh-autosuggestions.install b/zsh-autosuggestions.install
index 700bed59b4a1..5be4409caa45 100644
--- a/zsh-autosuggestions.install
+++ b/zsh-autosuggestions.install
@@ -1,8 +1,6 @@
post_install() {
echo "==> To use zsh autosuggestions, include the following snippet in your .zshrc:
source /usr/share/zsh/plugins/zsh-autosuggestions/autosuggestions.zsh
- zle-line-init() {
- zle autosuggest-start
- }
- zle -N zle-line-init"
+ ## if using zsh-syntax-highlighting, it should be sourced here, between the commands
+ autosuggest_start"
}