summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Stubbs2016-02-15 09:49:29 +0000
committerAndrew Stubbs2016-02-15 13:09:19 +0000
commit5c4ffb60d55b023c9568e14478f9da6b1f215284 (patch)
tree34fa3c373a1475f65e96b233056cd7e63fdc1ad2
parent26fea6d5183e4d77a61a035ee29e3a854829ae56 (diff)
downloadaur-5c4ffb60d55b023c9568e14478f9da6b1f215284.tar.gz
Update for new install process.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
-rw-r--r--zsh-autosuggestions.install4
3 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 764f121a1cc6..ef43670e7faa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zsh-autosuggestions-git
pkgdesc = Fish shell like fast/unobtrusive autosuggestions for zsh
- pkgver = 0.2.1.101.f154d25
+ pkgver = 0.2.1.119.76f415b
pkgrel = 1
url = https://github.com/tarruda/zsh-autosuggestions
install = zsh-autosuggestions.install
diff --git a/PKGBUILD b/PKGBUILD
index ef6905c7f8a8..6c7a71fbba10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name='zsh-autosuggestions'
-pkgname="${_name}-git"
-pkgver=0.2.1.101.f154d25
+pkgname=zsh-autosuggestions-git
+pkgver=0.2.1.119.76f415b
pkgrel=1
pkgdesc='Fish shell like fast/unobtrusive autosuggestions for zsh'
url='https://github.com/tarruda/zsh-autosuggestions'
@@ -20,14 +20,15 @@ pkgver() {
package() {
cd "${srcdir}/${_name}"
+ make -B zsh-autosuggestions.zsh
install -d "${pkgdir}/usr/share/zsh/plugins/${_name}"
- cp -a --no-preserve=ownership dist/autosuggestions.zsh "${pkgdir}/usr/share/zsh/plugins/${_name}"
+ cp -a --no-preserve=ownership "zsh-autosuggestions.zsh" "${pkgdir}/usr/share/zsh/plugins/${_name}"
# license
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
}
-#check() {
-# cd "${srcdir}/${_name}"
-# make test
-#}
+check() {
+ cd "${srcdir}/${_name}"
+ make test
+}
diff --git a/zsh-autosuggestions.install b/zsh-autosuggestions.install
index 5be4409caa45..2d0b4180a855 100644
--- a/zsh-autosuggestions.install
+++ b/zsh-autosuggestions.install
@@ -1,6 +1,4 @@
post_install() {
echo "==> To use zsh autosuggestions, include the following snippet in your .zshrc:
- source /usr/share/zsh/plugins/zsh-autosuggestions/autosuggestions.zsh
- ## if using zsh-syntax-highlighting, it should be sourced here, between the commands
- autosuggest_start"
+ source /usr/share/zsh/plugins/zsh-autosuggestions/zsh-autosuggestions.zsh"
}