summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramoka2021-01-05 23:24:10 -0500
committeramoka2021-01-05 23:24:10 -0500
commit9046b19319b148296587e84d63f173db5f58b8b9 (patch)
tree3ce1cad494c31a23e5573588ef4ad6258c9d1d9d
parent6bad78ae0e2c06b9bd2a784e9a217c8c4ce51ea0 (diff)
downloadaur-9046b19319b148296587e84d63f173db5f58b8b9.tar.gz
Adopt and update package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD57
-rw-r--r--zsh-autosuggestions.install4
3 files changed, 30 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1a67878615f..686dbda90c3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = zsh-autosuggestions-git
- pkgdesc = Fish shell like fast/unobtrusive autosuggestions for zsh
- pkgver = v0.4.3.r0.gd7c7967
+ pkgdesc = Fish-like autosuggestions for zsh (from git)
+ pkgver = 0.6.4.r0.gae315de
pkgrel = 1
url = https://github.com/zsh-users/zsh-autosuggestions
- install = zsh-autosuggestions.install
arch = any
- license = Custom:MIT
+ license = MIT
makedepends = git
- makedepends = ruby
- makedepends = tmux
- makedepends = ruby-rdoc
depends = zsh
provides = zsh-autosuggestions
- source = zsh-autosuggestions::git://github.com/zsh-users/zsh-autosuggestions
+ conflicts = zsh-autosuggestions
+ source = git+https://github.com/zsh-users/zsh-autosuggestions.git
sha256sums = SKIP
pkgname = zsh-autosuggestions-git
diff --git a/PKGBUILD b/PKGBUILD
index 34fa020d4d30..aee90daed989 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,37 @@
-_name='zsh-autosuggestions'
-pkgname="${_name}-git"
-pkgver=v0.4.3.r0.gd7c7967
+# Maintainer: Amanoel Dawod <amoka at amanoel dot com>
+# Contributor: Andrew Stubbs
+
+pkgname=zsh-autosuggestions-git
+pkgver=0.6.4.r0.gae315de
pkgrel=1
-pkgdesc='Fish shell like fast/unobtrusive autosuggestions for zsh'
-url='https://github.com/zsh-users/zsh-autosuggestions'
+pkgdesc="Fish-like autosuggestions for zsh (from git)"
arch=('any')
-license=('Custom:MIT')
+url="https://github.com/zsh-users/zsh-autosuggestions"
+license=('MIT')
depends=('zsh')
-makedepends=('git' 'ruby' 'tmux' 'ruby-rdoc')
+makedepends=('git')
provides=('zsh-autosuggestions')
-install="${_name}.install"
-source=("${_name}::${url//https/git}")
+conflicts=('zsh-autosuggestions')
+source=("git+https://github.com/zsh-users/zsh-autosuggestions.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_name}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd zsh-autosuggestions
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-package() {
- cd "${srcdir}/${_name}"
- make -B zsh-autosuggestions.zsh
- install -d "${pkgdir}/usr/share/zsh/plugins/${_name}"
- cp -a --no-preserve=ownership "zsh-autosuggestions.zsh" "${pkgdir}/usr/share/zsh/plugins/${_name}"
-
- # license
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
+build() {
+ cd zsh-autosuggestions
+ make
}
-check() {
- cd "${srcdir}/${_name}"
- (
- # The test script uses Ruby Gems.
- # Avoid installing them in the user's real home.
- export HOME=$PWD/tmphome
- export GEM_HOME=$(ruby -e 'print Gem.user_dir')
- export PATH=$GEM_HOME/bin:$PATH
- gem install bundler
- bundle install
-
- make test
- )
+package() {
+ cd zsh-autosuggestions
+ install -vDm 644 ${pkgname%-git}{,.plugin}.zsh \
+ -t "${pkgdir}/usr/share/zsh/plugins/${pkgname}/"
+ # docs
+ install -vDm 644 {CHANGELOG,README}.md \
+ -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ # license
+ install -vDm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
}
diff --git a/zsh-autosuggestions.install b/zsh-autosuggestions.install
deleted file mode 100644
index 2d0b4180a855..000000000000
--- a/zsh-autosuggestions.install
+++ /dev/null
@@ -1,4 +0,0 @@
-post_install() {
- echo "==> To use zsh autosuggestions, include the following snippet in your .zshrc:
- source /usr/share/zsh/plugins/zsh-autosuggestions/zsh-autosuggestions.zsh"
-}