summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Stubbs2017-06-07 10:17:10 +0100
committerAndrew Stubbs2017-06-07 10:17:10 +0100
commit996cdac2eed0e5ce04bddcaa5a1dbf4d46f53524 (patch)
tree1f1105661ab3ab5d7ed59a0125b3439ab58a2827
parent4f7655721eb47008e52876c1588ba80313a84a59 (diff)
downloadaur-996cdac2eed0e5ce04bddcaa5a1dbf4d46f53524.tar.gz
Fix test support
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a3d7be0e92d..0da278464f56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Thu Oct 20 09:32:57 UTC 2016
+# Wed Jun 7 09:12:29 UTC 2017
pkgbase = zsh-autosuggestions-git
pkgdesc = Fish shell like fast/unobtrusive autosuggestions for zsh
- pkgver = v0.3.3.r1.gfedc22e
+ pkgver = v0.4.0.r0.g2cb6eb6
pkgrel = 1
url = https://github.com/zsh-users/zsh-autosuggestions
install = zsh-autosuggestions.install
arch = any
license = Custom:MIT
makedepends = git
+ makedepends = ruby
depends = zsh
provides = zsh-autosuggestions
source = zsh-autosuggestions::git://github.com/zsh-users/zsh-autosuggestions
diff --git a/PKGBUILD b/PKGBUILD
index e36c98bdefb8..b29d4896afbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
_name='zsh-autosuggestions'
pkgname="${_name}-git"
-pkgver=v0.3.3.r1.gfedc22e
+pkgver=v0.4.0.r0.g2cb6eb6
pkgrel=1
pkgdesc='Fish shell like fast/unobtrusive autosuggestions for zsh'
url='https://github.com/zsh-users/zsh-autosuggestions'
arch=('any')
license=('Custom:MIT')
depends=('zsh')
-makedepends=('git')
+makedepends=('git' 'ruby')
provides=('zsh-autosuggestions')
install="${_name}.install"
source=("${_name}::${url//https/git}")
@@ -30,5 +30,15 @@ package() {
check() {
cd "${srcdir}/${_name}"
- make test
+ (
+ # The test script uses Ruby Gems.
+ # Avoid installing them in the user's real home.
+ export HOME=$PWD/tmphome
+ export GEM_HOME=$(ruby -e 'print Gem.user_dir')
+ export PATH=$GEM_HOME/bin:$PATH
+ gem install bundler
+ bundle install
+
+ make test
+ )
}