summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Zack2021-10-28 01:35:28 +1100
committerSimon Zack2021-10-28 19:15:45 +1100
commitf6ddbb32cd4d1cb19edb877ab0f9c5200527fa55 (patch)
tree1e06f661232db39fb7a4f7c902b4d7eb3061c41e
downloadaur-f6ddbb32cd4d1cb19edb877ab0f9c5200527fa55.tar.gz
working `PKGBUILD`
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6883bc9507ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = zsh-autoswitch-virtualenv-git
+ pkgdesc = ZSH plugin that switches python virtualenvs automatically as you move between directories.
+ pkgver = 3.3.2.r0.gecc53e3
+ pkgrel = 1
+ url = https://github.com/MichaelAquilina/zsh-autoswitch-virtualenv
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = pwgen
+ depends = python
+ depends = zsh
+ optdepends = python-pipenv: Pipenv integration
+ optdepends = python-poetry: Poetry integration
+ source = zsh-autoswitch-virtualenv::git+https://github.com/MichaelAquilina/zsh-autoswitch-virtualenv.git
+ md5sums = SKIP
+
+pkgname = zsh-autoswitch-virtualenv-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..25c0b17111fc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+zsh-autoswitch-virtualenv/
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..108fc0f31026
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Simon Zack <simonzack@gmail.com>
+pkgname=zsh-autoswitch-virtualenv-git
+pkgver=3.3.2.r0.gecc53e3
+pkgrel=1
+pkgdesc='ZSH plugin that switches python virtualenvs automatically as you move between directories.'
+arch=('any')
+url="https://github.com/MichaelAquilina/zsh-autoswitch-virtualenv"
+license=('GPL3')
+depends=('zsh' 'python' 'pwgen')
+makedepends=('git')
+optdepends=(
+ 'python-pipenv: Pipenv integration'
+ 'python-poetry: Poetry integration'
+)
+source=('zsh-autoswitch-virtualenv::git+https://github.com/MichaelAquilina/zsh-autoswitch-virtualenv.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/zsh-autoswitch-virtualenv"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm644 "${pkgname%-git}/autoswitch_virtualenv.plugin.zsh" \
+ "$pkgdir/usr/share/zsh/plugins/${pkgname%-git}/${pkgname%-git}.plugin.zsh"
+}