summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrestis Floros2020-06-14 10:10:03 +0200
committerOrestis Floros2020-06-14 10:13:44 +0200
commitf5d8a4baea98a75aba76101d13cb4db33843213c (patch)
treed407d89a8f6449f12ca1aba794ab3679a4f9235e
downloadaur-f5d8a4baea98a75aba76101d13cb4db33843213c.tar.gz
Add package
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD24
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1893135133d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Aug 17 10:14:48 UTC 2017
+pkgbase = zsh-background-notify-git
+ pkgdesc = Cross-platform background notifications for long running commands!
+ pkgver = r31.d5f0430
+ pkgrel = 1
+ url = https://github.com/t413/zsh-background-notify
+ arch = any
+ makedepends = git
+ depends = zsh
+ provides = zsh-background-notify
+ source = zsh-background-notify::git://github.com/t413/zsh-background-notify
+ sha256sums = SKIP
+
+pkgname = zsh-background-notify-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4f71dbe5af14
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8023f7f0fa65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Orestis Floros <orestisflo@gmail.com>
+_name='zsh-background-notify'
+pkgname="${_name}-git"
+pkgver=r31.d5f0430
+pkgrel=1
+pkgdesc="Cross-platform background notifications for long running commands!"
+url="https://github.com/t413/zsh-background-notify"
+arch=('any')
+depends=('zsh')
+makedepends=('git')
+provides=($_name)
+source=("${_name}::${url//https/git}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_name}"
+ install -d "${pkgdir}/usr/share/zsh/plugins/${_name}"
+ cp -a --no-preserve=ownership *.zsh "${pkgdir}/usr/share/zsh/plugins/${_name}"
+}