summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2024-08-18 21:35:14 +0300
committerYurii Kolesnykov2024-08-18 21:36:32 +0300
commitb4025488d54baaba9c5b96fa4053c72a6da0e9bf (patch)
tree84d28ae1f0b330c2ffdafca2caf6864e096a0eaa
parent6433b9de606c5b712160c6eae9b2cf0313124045 (diff)
downloadaur-b4025488d54baaba9c5b96fa4053c72a6da0e9bf.tar.gz
0.6
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD34
-rw-r--r--zsh-git-prompt.install15
4 files changed, 48 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5009b19c1ccc..8d7ddfbaa8b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
-# Generated by mksrcinfo v8
-# Mon Mar 20 10:34:13 UTC 2017
pkgbase = zsh-git-prompt
pkgdesc = Informative git prompt for zsh
- pkgver = 0.5
+ pkgver = 0.6
pkgrel = 1
- url = https://github.com/olivierverdier/zsh-git-prompt
+ url = https://github.com/zsh-git-prompt/zsh-git-prompt
+ install = zsh-git-prompt.install
arch = any
- license = MIT
- makedepends = git
- depends = zsh
- depends = python
- source = https://github.com/olivierverdier/zsh-git-prompt/archive/v0.5.tar.gz
- md5sums = 9e445ef5270cfccce2b907fa29c6af0c
+ license = LicenseRef-MIT
+ source = zsh-git-prompt-v0.6.tar.gz::https://github.com/zsh-git-prompt/zsh-git-prompt/archive/v0.6.tar.gz
+ sha256sums = b28a8249797b92b25e3c3156dc99153548a5b0877d2e6aa20be15caa719dcea2
pkgname = zsh-git-prompt
-
+ depends = zsh
+ depends = python
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..eeeab02e9c18
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!*.install
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 8d621663d1cb..a5c545adc9d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
-# $Id$
-# Maintainer: Thaodan <theodorstormgrade@gmail.com>
+# Maintainer: Yurii Kolesnykov <root@yurikoles.com>
+# Contributor: Thaodan <theodorstormgrade@gmail.com>
+#
+# Pull Requests are welcome here: https://github.com/yurikoles-aur/zsh-git-prompt
+
pkgname=zsh-git-prompt
-pkgver=0.5
+pkgver=0.6
pkgrel=1
-pkgdesc="Informative git prompt for zsh"
+pkgdesc='Informative git prompt for zsh'
arch=('any')
-url="https://github.com/olivierverdier/zsh-git-prompt"
-depends=('zsh' 'python')
-makedepends=('git')
-license=('MIT')
-source=("https://github.com/olivierverdier/zsh-git-prompt/archive/v$pkgver.tar.gz")
-md5sums=('9e445ef5270cfccce2b907fa29c6af0c')
-
+url="https://github.com/${pkgname}/${pkgname}"
+license=('LicenseRef-MIT')
+install="${pkgname}.install"
+source=("${pkgname}-v${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('b28a8249797b92b25e3c3156dc99153548a5b0877d2e6aa20be15caa719dcea2')
package() {
- cd "$srcdir"/$pkgname-$pkgver
- install -Dm755 gitstatus.py "$pkgdir"/usr/lib/$pkgname/gitstatus.py
- install -Dm755 zshrc.sh "$pkgdir"/usr/lib/$pkgname/zshrc.sh
+ depends=('zsh' 'python')
+
+ cd "${pkgname}-${pkgver}"
+
+ install -Dm755 zshrc.sh "${pkgdir}/usr/lib/${pkgname}/zshrc.sh"
+ install -Dm755 python/gitstatus.py "${pkgdir}/usr/lib/${pkgname}/python/gitstatus.py"
+ install -Dm755 shell/gitstatus.sh "${pkgdir}/usr/lib/${pkgname}/shell/gitstatus.sh"
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/zsh-git-prompt.install b/zsh-git-prompt.install
new file mode 100644
index 000000000000..eafc279c63a5
--- /dev/null
+++ b/zsh-git-prompt.install
@@ -0,0 +1,15 @@
+post_install() {
+ cat << EOF
+
+==> File to source is /usr/lib/zsh-git-prompt/zshrc.sh
+
+EOF
+}
+
+post_remove() {
+ cat << EOF
+
+==> Please make sure your zsh config no longer sources /usr/lib/zsh-git-prompt/zshrc.sh
+
+EOF
+}