aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Ronecker2018-08-07 14:46:52 +0200
committerPascal Ronecker2018-08-07 14:53:37 +0200
commitb9b038eaeec1d56a002dc9a1eed3abcd8c4498d0 (patch)
treee5135e151c6b4d53353dbe7a5f5d558391853007
downloadaur-b9b038eaeec1d56a002dc9a1eed3abcd8c4498d0.tar.gz
initial packaging
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
-rw-r--r--README.md7
-rwxr-xr-xupdateSRCINFO.sh1
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da799a99b685
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = zsh-git-prompt-git
+ pkgdesc = a nice and fast python based zsh-git-prompt (haskell support not packaged)
+ pkgver = v0.3.r129.g11b83ba
+ pkgrel = 1
+ url = https://github.com/starcraftman/zsh-git-prompt.git
+ arch = x86_64
+ arch = i686
+ license = MIT
+ depends = python>=2.7.1
+ source = zsh-git-prompt::git+https://github.com/starcraftman/zsh-git-prompt.git#branch=master
+ sha256sums = SKIP
+
+pkgname = zsh-git-prompt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55bac28f3bee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Squalou <squalou.jenkins [at] gmail [dot] com>
+pkgname=zsh-git-prompt-git
+pkgver=v0.3.r129.g11b83ba
+pkgrel=1
+pkgdesc="a nice and fast python based zsh-git-prompt (haskell support not packaged)"
+arch=('x86_64' 'i686')
+url="https://github.com/starcraftman/zsh-git-prompt.git"
+license=('MIT')
+depends=('python>=2.7.1')
+instdir=/etc/${pkgname%-git}
+
+[[ $CARCH == 'x86_64' ]] && _arch='x64' || _arch='ia32'
+
+source=("${pkgname%-git}::git+${url}#branch=master")
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+
+package() {
+ install -dm755 "${pkgdir}${instdir}"
+ install -Dm644 "${srcdir}/${pkgname%-git}/zshrc.sh" "${pkgdir}${instdir}/"
+ install -Dm644 "${srcdir}/${pkgname%-git}/gitstatus.py" "${pkgdir}${instdir}/"
+}
+
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..3a9bea69275e
--- /dev/null
+++ b/README.md
@@ -0,0 +1,7 @@
+This is a simple packaging of the existent project that can be found here :
+
+https://github.com/starcraftman/zsh-git-prompt
+
+Please check documentation there; lots of useful information are available.
+
+
diff --git a/updateSRCINFO.sh b/updateSRCINFO.sh
new file mode 100755
index 000000000000..bbe1d41c2213
--- /dev/null
+++ b/updateSRCINFO.sh
@@ -0,0 +1 @@
+makepkg --printsrcinfo > .SRCINFO