summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorByeonghoon Yoo2018-08-03 16:15:01 +0900
committerByeonghoon Yoo2018-08-03 16:15:01 +0900
commit9c7759614437505dd759286688d1c47453661ad9 (patch)
tree686d801b49d3401acb4ad0353284fa9381b2c0af
downloadaur-9c7759614437505dd759286688d1c47453661ad9.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..386b4340a062
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = zsh-history-search-multi-word-git
+ pkgdesc = Multi-word, syntax highlighted history searching for Zsh
+ pkgver = r285.73e7ea4
+ pkgrel = 1
+ url = https://github.com/zdharma/history-search-multi-word
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = zsh>=5.0.0
+ source = history-search-multi-word::git://github.com/zdharma/history-search-multi-word
+ sha512sums = SKIP
+
+pkgname = zsh-history-search-multi-word-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16aa87367440
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Byeonghoon Yoo <bh322yoo@gmail.com>
+
+_name='history-search-multi-word'
+
+pkgname="zsh-${_name}-git"
+pkgver=r285.73e7ea4
+pkgrel=1
+pkgdesc='Multi-word, syntax highlighted history searching for Zsh'
+arch=('any')
+license=('MIT')
+url='https://github.com/zdharma/history-search-multi-word'
+depends=('zsh>=5.0.0')
+makedepends=('git')
+source=("${_name}::${url//https/git}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${_name}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ typeset _plugindir="${pkgdir}/usr/share/zsh/plugins/${_name}"
+
+ cd "${srcdir}/${_name}"
+
+ install -dm0755 "${_plugindir}"
+ install -m644 history-search-multi-word* "${_plugindir}"
+ install -m644 hsmw-* "${_plugindir}"
+
+ # license
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
+}