summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfsckd2015-07-07 15:18:00 -0400
committerfsckd2015-07-07 15:18:00 -0400
commit1bf5f599023f20f048b40fc918bd56243a629970 (patch)
treeed70ae42fe7147b085ad198a1cd9cf7822c4d1fc
downloadaur-1bf5f599023f20f048b40fc918bd56243a629970.tar.gz
new AUR4 repository
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD32
-rw-r--r--zsh-history-substring-search-git.install14
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b23bab9d48f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = zsh-history-substring-search-git
+ pkgdesc = A ZSH plugin to search history, a clean-room implementation of the Fish shell feature
+ pkgver = 74.3bd84be
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/zsh-users/zsh-history-substring-search
+ install = zsh-history-substring-search-git.install
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = zsh
+ provides = zsh-history-substring-search
+ conflicts = zsh-history-substring-search
+ source = git://github.com/zsh-users/zsh-history-substring-search
+ md5sums = SKIP
+
+pkgname = zsh-history-substring-search-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f6fbe5b4dbe8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.src.tar.*
+*.pkg.tar.*
+src/
+pkg/
+
+zsh-history-substring-search/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dec128a47708
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: fsckd <fsckdaemon at gmail dot com>
+# Contributor: veox <veox at wre dot ath dot cx>
+
+pkgname=zsh-history-substring-search-git
+pkgver=74.3bd84be
+pkgrel=1
+epoch=1
+pkgdesc="A ZSH plugin to search history, a clean-room implementation of the Fish shell feature"
+arch=('any')
+url="https://github.com/zsh-users/zsh-history-substring-search"
+license=('BSD')
+depends=('zsh')
+makedepends=('git')
+provides=('zsh-history-substring-search')
+conflicts=('zsh-history-substring-search')
+install=zsh-history-substring-search-git.install
+source=('git://github.com/zsh-users/zsh-history-substring-search')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ local name="${pkgname%-git}"
+ cd "$srcdir/$name"
+ install -d -m755 "$pkgdir/usr/share/zsh/plugins/$name"
+ install -m644 README.md "$name".{zsh,plugin.zsh} "$pkgdir/usr/share/zsh/plugins/$name"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/zsh-history-substring-search-git.install b/zsh-history-substring-search-git.install
new file mode 100644
index 000000000000..ebe9cc17296b
--- /dev/null
+++ b/zsh-history-substring-search-git.install
@@ -0,0 +1,14 @@
+post_install() {
+cat << EOF
+==> To use, load the script (running terminal or $HOME/.zshrc):
+
+source /usr/share/zsh/plugins/zsh-history-substring-search/zsh-history-substring-search.zsh
+
+==> If you also want to use zsh-syntax-highlighting, make sure you load
+==> it before you load this script.
+EOF
+}
+
+post_upgrade() {
+post_install $1
+}