summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Gniazdowski2016-05-19 07:56:53 +0200
committerSebastian Gniazdowski2016-05-19 07:56:53 +0200
commit026d946e63c1996f42872af69ab3cb8f8effae8f (patch)
tree53af1d5b23d12bd14142d9d635364385bf86a0ed
downloadaur-026d946e63c1996f42872af69ab3cb8f8effae8f.tar.gz
[NEW] zsh-navigation-tools 2.1.16
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
-rw-r--r--zsh-navigation-tools.install4
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5624036ab84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = zsh-navigation-tools
+ pkgdesc = Curses-based tools for Zshell, e.g. multi-word history searcher
+ pkgver = 2.1.16
+ pkgrel = 1
+ url = http://github.com/psprint/zsh-navigation-tools
+ install = zsh-navigation-tools.install
+ arch = any
+ license = GPL
+ license = MIT
+ depends = zsh>=4.3.17
+ provides = zsh-navigation-tools
+ conflicts = zsh-navigation-tools
+ source = zsh-navigation-tools-2.1.16.tar.gz::https://github.com/psprint/zsh-navigation-tools/archive/v2.1.16.tar.gz
+ md5sums = 6fd660543dd3efa49c3d985e98a649db
+
+pkgname = zsh-navigation-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c75667ac8576
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+_name='zsh-navigation-tools'
+pkgname="${_name}"
+pkgver=2.1.16
+pkgrel=1
+pkgdesc="Curses-based tools for Zshell, e.g. multi-word history searcher"
+url="http://github.com/psprint/zsh-navigation-tools"
+arch=('any')
+license=('GPL' 'MIT')
+depends=('zsh>=4.3.17')
+provides=('zsh-navigation-tools')
+conflicts=('zsh-navigation-tools')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/psprint/${pkgname}/archive/v${pkgver}.tar.gz")
+install="${_name}.install"
+md5sums=('6fd660543dd3efa49c3d985e98a649db')
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ make DESTDIR="${pkgdir}" PREFIX='/usr' install
+}
diff --git a/zsh-navigation-tools.install b/zsh-navigation-tools.install
new file mode 100644
index 000000000000..da7af926ddda
--- /dev/null
+++ b/zsh-navigation-tools.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "==> To use Zsh Navigation Tools, include the following line in your .zshrc:
+ source /usr/share/zsh-navigation-tools/zsh-navigation-tools.plugin.zsh"
+}