summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2022-11-08 22:33:15 -0500
committeréclairevoyant2022-11-08 22:33:15 -0500
commitf38c257ac488ecfd4e24d6f004579502a34896ba (patch)
tree9c1af939ce079f6c033b2ad84578e7c7bee4c8a6
downloadaur-f38c257ac488ecfd4e24d6f004579502a34896ba.tar.gz
init
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b62f134ab42c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = zsh-nix-shell
+ pkgdesc = zsh plugin that lets you use zsh in nix-shell shells
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/chisui/zsh-nix-shell
+ arch = any
+ license = BSD
+ depends = zsh
+ conflicts = zsh-nix-shell-git
+ source = zsh-nix-shell-0.5.0.tar.gz::https://github.com/chisui/zsh-nix-shell/archive/refs/tags/v0.5.0.tar.gz
+ sha256sums = ea931422e302c5e54063c2d77c882d32c6e1bc8ea58031652ba55cfd91c5fbb5
+
+pkgname = zsh-nix-shell
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76f5bcbb6ed3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: éclairevoyant
+
+pkgname=zsh-nix-shell
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="zsh plugin that lets you use zsh in nix-shell shells"
+arch=('any')
+url="https://github.com/chisui/zsh-nix-shell"
+license=('BSD')
+depends=('zsh')
+conflicts=("$pkgname-git")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('ea931422e302c5e54063c2d77c882d32c6e1bc8ea58031652ba55cfd91c5fbb5')
+
+package() {
+ cd $pkgname-$pkgver
+
+ install -Dm644 nix-shell.plugin.zsh -t "$pkgdir/usr/share/zsh/plugins/$pkgname/"
+ install -Dm755 ./scripts/buildShellShim -t "$pkgdir/usr/share/zsh/plugins/$pkgname/scripts/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}
+