summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWieland Hoffmann2015-11-19 10:18:27 +0100
committerWieland Hoffmann2015-11-19 10:18:27 +0100
commit5c5ded006e521566683613b0c853da83f3e5fb73 (patch)
treef6ac5190031373a9296f513c20b301e7c387549a
downloadaur-5c5ded006e521566683613b0c853da83f3e5fb73.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fef55590ee3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = zsh-notify-git
+ pkgdesc = Desktop notifications for long-running commands in zsh.
+ pkgver = 29.cf8c1b9
+ pkgrel = 1
+ url = https://github.com/marzocchi/zsh-notify
+ arch = any
+ license = Custom:none
+ makedepends = git
+ depends = zsh
+ provides = zsh-notify
+ source = zsh-notify::git://github.com/marzocchi/zsh-notify
+ sha256sums = SKIP
+
+pkgname = zsh-notify-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6901496f02db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_name='zsh-notify'
+pkgname="${_name}-git"
+pkgver=29.cf8c1b9
+pkgrel=1
+pkgdesc="Desktop notifications for long-running commands in zsh."
+url="https://github.com/marzocchi/zsh-notify"
+arch=('any')
+license=('Custom:none')
+depends=('zsh')
+makedepends=('git')
+provides=('zsh-notify')
+source=("${_name}::${url//https/git}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ echo "$(git rev-list --count HEAD).$(git describe --always )"
+}
+
+package() {
+ cd "${srcdir}/${_name}"
+ install -d "${pkgdir}/usr/share/zsh/plugins/${_name}"
+ cp -a --no-preserve=ownership * "${pkgdir}/usr/share/zsh/plugins/${_name}"
+}