summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSabu Siyad2021-08-26 02:11:41 +0530
committerSabu Siyad2021-08-26 02:11:41 +0530
commit9eecc9cd26c7ce70fe7a0b5e36ee27f4d77502cb (patch)
tree355dbaf2343aeaad3eac01411478e9e16282c40f
downloadaur-9eecc9cd26c7ce70fe7a0b5e36ee27f4d77502cb.tar.gz
Initial upload: zsh-plugin-wd 0.5.1-1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD38
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3bd3b5507723
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = zsh-plugin-wd
+ pkgdesc = Jump to custom directories in zsh
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://github.com/mfaerevaag/wd
+ arch = x86_64
+ license = MIT
+ depends = zsh
+ provides = zsh-plugin-wd
+ conflicts = zsh-plugin-wd
+ conflicts = zsh-plugin-wd
+ source = wd::https://github.com/mfaerevaag/wd/archive/refs/tags/v0.5.1.zip
+ sha256sums = 1b89eba72840c17fdc42899f2269a25a442c56baad6f13b44278f866806a475f
+
+pkgname = zsh-plugin-wd
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..62d30f9218cb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84807ea358c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Sabu Siyad <hello at ssiyad dot com>
+# This PKGBUILD is maintained at https://github.com/ssiyad/pkgbuilds/
+
+pkgname=zsh-plugin-wd
+_pkgname=wd
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="Jump to custom directories in zsh"
+arch=('x86_64')
+url="https://github.com/mfaerevaag/wd"
+license=("MIT")
+depends=("zsh")
+provides=("$pkgname")
+conflicts=(
+ "${pkgname%-git}"
+ "$pkgname"
+)
+source=(
+ "$_pkgname::${url}/archive/refs/tags/v${pkgver}.zip"
+)
+sha256sums=("1b89eba72840c17fdc42899f2269a25a442c56baad6f13b44278f866806a475f")
+
+prepare() {
+ mkdir -p $pkgdir/usr/share/$_pkgname $pkgdir/usr/share/man/man1 $pkgdir/usr/share/licenses/$pkgname $pkgdir/usr/share/zsh/site-functions
+}
+
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+ gzip -f wd.1
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ install -Dm755 wd.sh $pkgdir/usr/share/$_pkgname/wd.sh
+ install -Dm755 wd.1.gz $pkgdir/usr/share/man/man1/wd.1.gz
+ install -Dm755 LICENSE $pkgdir/usr/share/licenses/$pkgname
+ install -Dm755 _wd.sh $pkgdir/usr/share/zsh/site-functions/_wd
+}