summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Greve2016-11-02 10:14:20 -0400
committerDaniel Greve2016-11-02 10:14:20 -0400
commitc466e61e4213afb4c653a79af1a532aef2f52cbb (patch)
tree2a6470df8666a63d6ca39494422898291dc9d085
downloadaur-c466e61e4213afb4c653a79af1a532aef2f52cbb.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33f0ad684da6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = zsh-pure-prompt
+ pkgdesc = Pretty, minimal and fast ZSH prompt
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://github.com/sindresorhus/pure
+ arch = any
+ license = MIT
+ depends = git>=2.0.0
+ depends = zsh>=5.0.0
+ source = https://github.com/sindresorhus/pure/archive/v1.4.0.tar.gz
+ md5sums = 081160fadb06ca87923ee1f2061a7ba0
+
+pkgname = zsh-pure-prompt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d20bd3778744
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Daniel Greve <greve.daniel.l@gmail.com>
+
+pkgname=zsh-pure-prompt
+pkgver=1.4.0
+pkgrel=1
+pkgdesc='Pretty, minimal and fast ZSH prompt'
+arch=('any')
+url='https://github.com/sindresorhus/pure'
+license=('MIT')
+depends=('git>=2.0.0' 'zsh>=5.0.0')
+source=("https://github.com/sindresorhus/pure/archive/v${pkgver}.tar.gz")
+md5sums=('081160fadb06ca87923ee1f2061a7ba0')
+
+package() {
+ cd "${srcdir}/pure-${pkgver}"
+ install -Dm644 pure.zsh "${pkgdir}/usr/share/zsh/functions/Prompts/prompt_pure_setup"
+ install -Dm644 async.zsh "${pkgdir}/usr/share/zsh/functions/Prompts/async"
+ install -Dm644 license "${pkgdir}/usr/share/licenses/zsh-pure-prompt/license"
+}