summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Greve2016-10-31 17:38:38 -0400
committerDaniel Greve2016-10-31 17:38:38 -0400
commitcf3b02cf3d5e09980aaa149f6e88b5c9b6ca5544 (patch)
tree7a48e5e7ccd674da775a75963fa8b7498987efc7
downloadaur-cf3b02cf3d5e09980aaa149f6e88b5c9b6ca5544.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6f3bba834ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = zsh-pure-prompt-git
+ pkgdesc = Pretty, minimal and fast ZSH prompt
+ pkgver = 1.4.0.r8.gecae2cc
+ pkgrel = 1
+ url = https://github.com/sindresorhus/pure
+ arch = any
+ license = MIT
+ depends = git>=2.0.0
+ depends = zsh>=5.0.0
+ source = git+https://github.com/sindresorhus/pure.git
+ md5sums = SKIP
+
+pkgname = zsh-pure-prompt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cd00788eff0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Daniel Greve <greve.daniel.l@gmail.com>
+
+pkgname=zsh-pure-prompt-git
+pkgver=1.4.0.r8.gecae2cc
+pkgrel=1
+pkgdesc='Pretty, minimal and fast ZSH prompt'
+arch=('any')
+url='https://github.com/sindresorhus/pure'
+license=('MIT')
+depends=('git>=2.0.0' 'zsh>=5.0.0')
+source=('git+https://github.com/sindresorhus/pure.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/pure"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/pure"
+ install -Dm644 pure.zsh "${pkgdir}/usr/share/zsh/functions/Prompts/prompt_pure_setup"
+ install -Dm644 async.zsh "${pkgdir}/usr/share/zsh/functions/Prompts/async"
+}