summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhalosghost2015-11-22 15:06:14 -0600
committerhalosghost2015-11-22 15:06:14 -0600
commit0662252ca421d75eda701945de0b94db7527cd9d (patch)
treeccac79c45239f9040587cb2c5e70a89df3e5c340
parent139e85afdb72ba6cd70d0d74249a6d21f0048fda (diff)
downloadaur-0662252ca421d75eda701945de0b94db7527cd9d.tar.gz
Use the fancypants new `make install` rule
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b037039b6a4a..c16694016344 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zsh-syntax-highlighting-git
pkgdesc = Fish shell like syntax highlighting for Zsh
- pkgver = 0.2.1.228.3dc5741
+ pkgver = 0.2.1.452.e60737d
pkgrel = 1
url = https://github.com/zsh-users/zsh-syntax-highlighting
install = zsh-syntax-highlighting.install
@@ -8,6 +8,8 @@ pkgbase = zsh-syntax-highlighting-git
license = Custom
makedepends = git
depends = zsh>=4.3.9
+ provides = zsh-syntax-highlighting
+ conflicts = zsh-syntax-highlighting
source = zsh-syntax-highlighting::git://github.com/zsh-users/zsh-syntax-highlighting
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4327ad481465..623929932bdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: mjheagle <mjheagle8@gmail.com>
_name='zsh-syntax-highlighting'
pkgname="${_name}-git"
-pkgver=0.2.1.230.85b3446
+pkgver=0.2.1.452.e60737d
pkgrel=1
pkgdesc='Fish shell like syntax highlighting for Zsh'
url='https://github.com/zsh-users/zsh-syntax-highlighting'
@@ -23,6 +23,5 @@ pkgver() {
package() {
cd "${srcdir}/${_name}"
- install -d "${pkgdir}/usr/share/zsh/plugins/${_name}"
- cp -a --no-preserve=ownership * "${pkgdir}/usr/share/zsh/plugins/${_name}"
+ make DESTDIR="${pkgdir}" install
}