summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramoka2021-01-08 17:51:51 -0500
committeramoka2021-01-08 17:51:51 -0500
commit751640c5edadb0ef21d125d717169dd56c434e3b (patch)
treefd89fb9d333a79e6105ac042bd4c35558236711a
parent7a3aca57ff5674a64f889f93a5790b071f250d21 (diff)
downloadaur-751640c5edadb0ef21d125d717169dd56c434e3b.tar.gz
Adopt and update package
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD45
-rw-r--r--zsh-syntax-highlighting.install8
3 files changed, 40 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0ed0078cbec..d1a6c13083f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
-# Generated by mksrcinfo v8
-# Tue Sep 20 12:36:25 UTC 2016
pkgbase = zsh-syntax-highlighting-git
- pkgdesc = Fish shell like syntax highlighting for Zsh
- pkgver = 0.4.0.r167.gfdaeec4
+ pkgdesc = Fish shell like syntax highlighting for Zsh (from git)
+ pkgver = 0.8.0.alpha1.pre.redrawhook.r46.g5eb4948
pkgrel = 1
url = https://github.com/zsh-users/zsh-syntax-highlighting
install = zsh-syntax-highlighting.install
arch = any
- license = Custom
+ license = BSD
makedepends = git
depends = zsh>=4.3.9
provides = zsh-syntax-highlighting
conflicts = zsh-syntax-highlighting
- source = zsh-syntax-highlighting::git://github.com/zsh-users/zsh-syntax-highlighting
+ source = git+https://github.com/zsh-users/zsh-syntax-highlighting.git
sha256sums = SKIP
pkgname = zsh-syntax-highlighting-git
diff --git a/PKGBUILD b/PKGBUILD
index 0d585a6aa53c..e2e21c5e9455 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,42 @@
-# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
+# Maintainer: Amanoel Dawod <amoka at amanoel dot com>
+# Contributor: Sam Stuewe <halosghost at archlinux dot info>
# Contributor: mjheagle <mjheagle8@gmail.com>
-_name='zsh-syntax-highlighting'
-pkgname="${_name}-git"
-pkgver=0.4.0.r167.gfdaeec4
+
+_pkgname=zsh-syntax-highlighting
+pkgname="${_pkgname}-git"
+pkgver=0.8.0.alpha1.pre.redrawhook.r46.g5eb4948
pkgrel=1
-pkgdesc='Fish shell like syntax highlighting for Zsh'
-url='https://github.com/zsh-users/zsh-syntax-highlighting'
+pkgdesc="Fish shell like syntax highlighting for Zsh (from git)"
arch=('any')
-license=('Custom')
+url="https://github.com/zsh-users/zsh-syntax-highlighting"
+license=('BSD')
depends=('zsh>=4.3.9')
makedepends=('git')
-provides=('zsh-syntax-highlighting')
-conflicts=('zsh-syntax-highlighting')
-install="${_name}.install"
-source=("${_name}::${url//https/git}")
+provides=($_pkgname)
+conflicts=($_pkgname)
+install="${_pkgname}.install"
+source=("git+$url.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_name}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_pkgname
+ make
}
package() {
- cd "${srcdir}/${_name}"
- make DESTDIR="${pkgdir}" PREFIX='/usr' install
+ cd $_pkgname
+ make PREFIX="/usr" SHARE_DIR="${pkgdir}/usr/share/zsh/plugins/$_pkgname" DESTDIR="${pkgdir}" install
+ # create symlink for using with oh-my-zsh
+ ln -s "zsh-syntax-highlighting.zsh" \
+ "${pkgdir}/usr/share/zsh/plugins/$_pkgname/zsh-syntax-highlighting.plugin.zsh"
+
+ # licence
+ install -dm755 "${pkgdir}/usr/share/licenses/$_pkgname"
+ ln -s "/usr/share/doc/$_pkgname/COPYING.md" \
+ "${pkgdir}/usr/share/licenses/$_pkgname/COPYING"
}
diff --git a/zsh-syntax-highlighting.install b/zsh-syntax-highlighting.install
index 4777d1904289..98ad7db766d0 100644
--- a/zsh-syntax-highlighting.install
+++ b/zsh-syntax-highlighting.install
@@ -1,4 +1,8 @@
post_install() {
- echo "==> To use syntax highlighting, include the following line in your .zshrc:
- source /usr/share/zsh-syntax-highlighting/zsh-syntax-highlighting.zsh"
+ cat << EOF
+To activate zsh-syntax-highlighting, add the following line at the end of ~/.zshrc:
+ source /usr/share/zsh/plugins/zsh-syntax-highlighting/zsh-syntax-highlighting.zsh
+EOF
}
+
+# vim:set ts=2 sw=2 et: