summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYusuf Aktepe2020-03-16 02:51:21 +0300
committerYusuf Aktepe2020-03-16 02:51:21 +0300
commit3ad32b72a16d85e66590c1994dad1957ba1a971e (patch)
treea854ff382540f7f22e8ba88e2e8a8625cea19fde
downloadaur-3ad32b72a16d85e66590c1994dad1957ba1a971e.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
-rw-r--r--zsh-system-clipboard-git.install6
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2d161894e5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = zsh-system-clipboard-git
+ pkgdesc = Synchronize system clipboard with ZLE (Zsh Line Editor) registers
+ pkgver = r99.461cbbd
+ pkgrel = 1
+ url = https://github.com/kutsan/zsh-system-clipboard
+ install = zsh-system-clipboard-git.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = zsh
+ optdepends = xclip: clipboard utility
+ optdepends = xsel: clipboard utility
+ source = zsh-system-clipboard::git+https://github.com/kutsan/zsh-system-clipboard.git
+ sha256sums = SKIP
+
+pkgname = zsh-system-clipboard-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c0b84e2be0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Yusuf Aktepe <yusuf@yusufaktepe.com>
+
+_name=zsh-system-clipboard
+pkgname="${_name}-git"
+pkgver=r99.461cbbd
+pkgrel=1
+pkgdesc='Synchronize system clipboard with ZLE (Zsh Line Editor) registers'
+arch=('any')
+url="https://github.com/kutsan/zsh-system-clipboard"
+license=('GPL3')
+depends=('zsh')
+makedepends=('git')
+optdepends=(
+ 'xclip: clipboard utility'
+ 'xsel: clipboard utility'
+)
+install="${pkgname}.install"
+source=("${_name}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_name}"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_name}"
+ install -Dm644 "${_name}.zsh" -t "$pkgdir/usr/share/zsh/plugins/${_name}"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/${_name}"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${_name}"
+}
diff --git a/zsh-system-clipboard-git.install b/zsh-system-clipboard-git.install
new file mode 100644
index 000000000000..c630cf64e708
--- /dev/null
+++ b/zsh-system-clipboard-git.install
@@ -0,0 +1,6 @@
+post_install() {
+ cat <<EOF
+To activate zsh-system-clipboard, add the following line to your zshrc:
+ source /usr/share/zsh/plugins/zsh-system-clipboard/zsh-system-clipboard.zsh
+EOF
+}