summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrii Burkivskyi2019-12-19 10:28:26 +0100
committerAndrii Burkivskyi2019-12-19 10:28:26 +0100
commit21faf0d0cb015ed1baba12a86a38473d75b81c7e (patch)
tree23ec1f17bcaf068f1469298e801474d7dbd4a324
downloadaur-21faf0d0cb015ed1baba12a86a38473d75b81c7e.tar.gz
added sources, PKGBUILD & .SRCINFO
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--zsh-systemd-git.install8
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0616ede7803a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = zsh-systemd-git
+ pkgdesc = The systemd plugin for Zshell provides many useful aliases for systemd.
+ pkgver = r1.0d6af3e
+ pkgrel = 1
+ url = https://github.com/le0me55i/zsh-systemd
+ install = zsh-systemd-git.install
+ arch = any
+ makedepends = git
+ depends = zsh
+ provides = zsh-systemd
+ conflicts = zsh-systemd
+ source = git+https://github.com/le0me55i/zsh-systemd.git
+ sha256sums = SKIP
+
+pkgname = zsh-systemd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aef624cb7401
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Andrii Burkivskyi <buryk212@gmail.com>
+_gitname='zsh-systemd'
+pkgname="${_gitname}-git"
+pkgver=r1.0d6af3e
+pkgrel=1
+pkgdesc="The systemd plugin for Zshell provides many useful aliases for systemd."
+arch=('any')
+url="https://github.com/le0me55i/zsh-systemd"
+depends=('zsh')
+makedepends=('git')
+provides=('zsh-systemd')
+conflicts=('zsh-systemd')
+source=('git+https://github.com/le0me55i/zsh-systemd.git')
+install=zsh-systemd-git.install
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+
+ install -Dm644 systemd.plugin.zsh "${pkgdir}/usr/share/zsh/plugins/${_gitname}/systemd.plugin.zsh"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${_gitname}/README.md"
+}
+
diff --git a/zsh-systemd-git.install b/zsh-systemd-git.install
new file mode 100644
index 000000000000..26a2c7bf5dbe
--- /dev/null
+++ b/zsh-systemd-git.install
@@ -0,0 +1,8 @@
+post_install() {
+ cat<<<"
+To use, source the library from your .zshrc:
+
+ source /usr/share/zsh/plugins/zsh-systemd/systemd.plugin.zsh
+"
+}
+