summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenrique Mayer2022-02-09 17:14:56 -0300
committerHenrique Mayer2022-02-09 17:14:56 -0300
commit9c5af6fc5d9a31d473fac6389f30a3adbebff2db (patch)
treed46f1caecfc6083f34a582acc118d8fa1afba71d
downloadaur-9c5af6fc5d9a31d473fac6389f30a3adbebff2db.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rwxr-xr-x.install39
-rw-r--r--PKGBUILD29
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c955c5674cb1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = zsh-thefuck-git
+ pkgdesc = ZSH plugin. Initialize thefuck with cache support
+ pkgver = r6.136b5a2
+ pkgrel = 1
+ url = https://github.com/laggardkernel/zsh-thefuck
+ install = .install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = thefuck
+ depends = zsh
+ provides = zsh-thefuck-git
+ conflicts = zsh-thefuck-git
+ source = git+https://github.com/laggardkernel/zsh-thefuck.git
+ sha512sums = SKIP
+
+pkgname = zsh-thefuck-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4d1d14332e27
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+zsh-thefuck/
+zsh-thefuck-git-*.pkg.tar.zst
diff --git a/.install b/.install
new file mode 100755
index 000000000000..b86ae9843ba2
--- /dev/null
+++ b/.install
@@ -0,0 +1,39 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+## arg 1: the new package version
+#pre_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+post_install() {
+ echo "Add the next line to your ~/.zshrc file:"
+ echo ""
+ echo "source '/usr/share/zsh/plugins/zsh-thefuck-git/zsh-thefuck.plugin.zsh'"
+ echo ""
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#pre_upgrade() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#post_upgrade() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#post_remove() {
+ # do something here
+#}
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5678c6b4571
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Henrique Mayer <hmayer@gmail.com>
+
+pkgname=zsh-thefuck-git
+pkgver=r6.136b5a2
+pkgrel=2
+pkgdesc="ZSH plugin. Initialize thefuck with cache support"
+arch=("any")
+url="https://github.com/laggardkernel/zsh-thefuck"
+license=('MIT')
+depends=('thefuck' 'zsh')
+makedepends=('git')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+source=("git+https://github.com/laggardkernel/zsh-thefuck.git")
+sha512sums=('SKIP')
+install=".install"
+
+pkgver() {
+ cd "zsh-thefuck/"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/zsh-thefuck"
+ install -Dm 755 "init.zsh" "${pkgdir}/usr/share/zsh/plugins/${pkgname}/init.zsh"
+ install -Dm 755 "zsh-thefuck.plugin.zsh" "${pkgdir}/usr/share/zsh/plugins/${pkgname}/zsh-thefuck.plugin.zsh"
+ install -Dm 744 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+